Topic: No longer able to add a new gallery

I have a WordPress 3.4 website with version 2.3.0 of the Pro plug-in.  I have several pages with galleries working fine.  However when I went to add a new page and gallery I got the following error message:

"You don't have permission to access /wp-content/plugins/wp-simpleviewer/config.php on this server."

The last time I added a gallery was around October 2011.  Since then I have updated WordPress and the plug-in.  I have also subscribed to an anti-virus monitoring service.  I tried deactivating the plug-in that came with that service but got the same error.

Is there a permissions setting to change?

Re: No longer able to add a new gallery

You could check the permissions on the '/wp-content/plugins/wp-simpleviewer/' folder (changing all folders and subfolders to 777 and all files to 644) to see if this makes a difference.
Also, make sure that the user you have logged in as in your WordPress installation when you try to create the gallery has the Role of Administrator.
Also, having done a web search for the error message you receive, this might be related to your host and mod_security.
A possible fix can be found in this WordPress forum thread (though you would need to put the .htaccess file in the 'wp-simpleviewer' folder).
You could also check whether it is directly related to your updated version of WP-SimpleViewer by reverting to the previous version of WP-SimpleViewer (available for download here) to see if you still get the error.

Steven Speirs
SimpleViewer Support Team.

Re: No longer able to add a new gallery

Thanks for your quick reply Steven.

All the folder permissions were set to 755.  I was able to change all of them to 777 except the top 'wp-content/plugins/wp-simpleviewer'  folder.  That one would not change.  I tried changing the permissions on the folders above that also with no luck.

I got the same "no permission to access" error message with all the subfolders changed to 777 and the top folder still at 755.  The possible fix using .htaccess is way beyond my skill level with this.  Too scary for me to try.

I'll try working with the security service.  They did some work to "harden" the site.  I expect they set some parameter.

Re: No longer able to add a new gallery

The possible fix using .htaccess is way beyond my skill level with this.  Too scary for me to try.

It is actually relatively simple.
(1) Create a text file on your desktop.
(2) Open the text file and type or paste the following code:

<IfModule mod_security.c>
SecFilterInheritance Off
</IfModule>

(3) Save the file.
(4) Upload the file to your '/wp-content/plugins/wp-simpleviewer/' directory via FTP.
(5) Rename the file to '.htaccess;.

I'll try working with the security service.  They did some work to "harden" the site.  I expect they set some parameter.

Hopefully your web host can help you out further.

Steven Speirs
SimpleViewer Support Team.

Re: No longer able to add a new gallery

Alas, no luck.  I carefully created the .htaccess and put it first in the '/wp-content/plugins/wp-simpleviewer/'  and then the wp-admin/  folder.  All the folder permissions were set to 777 (except the top one which I couldn't change from 755) and files to 644.

I'm going on a vacation now and will contact the host provider when I get back.

Thanks again for trying to help.