Topic: About ActionScript 3.0

I have research a lot about this and could not find any answers sad

Question:

  • Does PostcardViewer-Pro support ActionScript 3.0 ?

  • If it is not is there any plan to support ActionScirpt 3.0 in the future?

  • Is there any suggestion for that?

Reason:
I am a user of ProstcardViewer-Pro, I am going to customize the ActionScripts of ProstcardViewer-Pro, but I find out that it is written by ActionScript 2.0. I failed to change/convert it to ActionScript 3.0 (too many problems to solve),
and I want to use some advanced features of ActionScripts 3.0 like ULRRequest/ULRLoader.

Re: About ActionScript 3.0

Does PostcardViewer-Pro support ActionScript 3.0 ?

No. As documented on this page:

Embedding PostcardViewer-Pro in Flash requires the embedding movie to be ActionScript 2 and requires Adobe Flash 8 (or later) authoring software. Embedding PostcardViewer-Pro in Flash requires a basic level of Flash authoring experience.

If it is not is there any plan to support ActionScirpt 3.0 in the future?

As far as I am aware, there are no plans for PostcardViewer-Pro to support ActionScript 3.0 in the future.

Is there any suggestion for that?

You might like to take a look at SWFBridge.

Steven Speirs
SimpleViewer Support Team.

Re: About ActionScript 3.0

thank you very much for your fast reply, You point out the right way I should go for. wink