Topic: background transparency again

hi guys i checked other topics about this but the advice given doesnt seam to resolve the problem so im going to post the code and if you can point out the mistake cuz i cant figure it out the param is set to true and still the background is visible

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
    <head>
        <title>Untitled-1</title>
        <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
        <style type="text/css" media="screen">
        html, body { height:100%; background-color: #000000;}
        body { margin:0; padding:0; overflow:hidden; }
        #flashContent { width:100%; height:100%; }
       
div.menu {
    position: absolute;
    top: 50%;
    left: 50%;
    margin-left: -850px;
    margin-top: -25%;
    height: 100%;
    width: 100%;
    z-index: 3;
    /*opacity:1;
      filter:alpha(opacity=90);*/
}
div.fla {
    position: absolute;
    top: 50%;
    left: 50%;
    margin-left: -450px;
    margin-top: -250px;
    height:500px;
    width: 900px;
    z-index: 1;
    /*opacity:0.6;
      filter:alpha(opacity=60);*/
}

div.cont {
    position: absolute;
    height:450px;
    width: 800px;
    left: 50%;
    top: 50%;
    margin-left: -400px;
    margin-top: -225px;
    z-index: 2;
    /*background: url(mainw.jpg);
    border: 1px #FFF;
    color:#0C0;
    opacity:0.2;
    filter:alpha(opacity=20);
    background-color: #000000;*/
}
html {
        height: 100%;
        overflow: hidden;
    }

    #flashcontent {
        height: 100%;
    }
    /* end hide */

    body {
        height: 100%;
        margin: 0;
        padding: 0;
        color:#ffffff;
        font-family:sans-serif;
        font-size:40;
    }

    a {
        color:#cccccc;
    }
        </style>
    </head>
    <body>   
    <script type="text/javascript">
                var so = new SWFObject("wmode.swf", "wmode.swf", "550", "400", "8","#ffffff");
                so.addParam("wmode", "opaque");
                so.write("flash");
</script>   
          <div align="center">
            <div class="cont"></div>
              <div class="menu">   
    <script type="text/javascript" src="swfobject.js"></script>
<div id="flashcontent">TiltViewer requires JavaScript and the latest Flash player.
<a href="http://www.macromedia.com/go/getflashplayer/">Get Flash here.</a></div>
<script type="text/javascript">
var fo = new SWFObject("TiltViewer.swf", "viewer", "100%", "100%", "9.0.28", "#000000");


// XML GALLERY OPTIONS
// To use local images defined in an XML document, use this block
fo.addVariable("useFlickr", "false");
fo.addVariable("xmlURL", "gallery.xml");
fo.addVariable("maxJPGSize","800");

//GENERAL OPTIONS
fo.addParam("wmode", "transparent");
fo.addVariable("bkgndTransparent", "true");
fo.addVariable("showFullscreenOption", "false");

fo.addVariable("useReloadButton", "false");
fo.addVariable("columns", "5"); fo.addVariable("rows", "3");
//fo.addVariable("bkgndInnerColor", "0xFFFFFF");
//fo.addVariable("bkgndOuterColor", "0xFFFFFF");
fo.addVariable("frameColor", "0xffffff");
//fo.addVariable("navButtonColor", "0x000000");
fo.addVariable("showFlipButton", "false");
fo.addVariable("showLinkButton", "false");
//fo.addVariable("linkLabel", "View image info");
//fo.addVariable("backColor", "0xDDDDDD");
//fo.addVariable("langGoFull", "Go Fullscreen");
//fo.addVariable("langExitFull", "Exit Fullscreen");
//fo.addVariable("langAbout", "About");
// END TILTVIEWER CONFIGURATION OPTIONS

fo.addParam("allowFullScreen","false");
fo.write("flashcontent");
</script>
   
    </div>
            <div class="fla">
            <div id="flashContent" style="z-index: 1;">
            <object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" width="900" height="500" id="Untitled-1" align="middle">
                <param name="movie" value="Untitled-1.swf" />
                <param name="quality" value="high" />
                <param name="bgcolor" value="#000000" />
                <param name="play" value="true" />
                <param name="loop" value="true" />
                <param name="scale" value="showall" />
                <param name="menu" value="true" />
                <param name="devicefont" value="false" />
                <param name="salign" value="" />
                <param name="allowScriptAccess" value="sameDomain" />
                <param name="wmode" value="opaque" />
                <!--[if !IE]>-->
                <object type="application/x-shockwave-flash" data="Untitled-1.swf" width="900" height="500">
                    <param name="movie" value="Untitled-1.swf" />
                    <param name="quality" value="high" />
                    <param name="bgcolor" value="#000000" />
                    <param name="play" value="true" />
                    <param name="loop" value="true" />
                    /*<param name="wmode" value="window" />*/
                    <param name="scale" value="showall" />
                    <param name="menu" value="true" />
                    <param name="devicefont" value="false" />
                    <param name="salign" value="" />
                    <param name="allowScriptAccess" value="sameDomain"/>
                    <param name="wmode" value="opaque" />
                <!--<![endif]-->
                    <a href="http://www.adobe.com/go/getflash">
                        <img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash player" />
                    </a>
                <!--[if !IE]>-->
                </object>
                <!--<![endif]-->
            </object>
            </div>
        </div>
    </body>
</html>


where do i go wrong?

Re: background transparency again

Using your code as the 'index.html' page in a TiltViewer-Pro test gallery, the background of the gallery is transparent (which can be confirmed by changing the background-color of the page's <body> tag).
If you have recently made any changes to your gallery, you may have to clear your browser's cache before reloading the gallery in order to see the changes.
If you continue to experience difficulties, please post the URL to your web page so that I can take a look.

Steven Speirs
SimpleViewer Support Team.