Topic: Galleries not displaying

I've been using Simpleviewer embedded in sites for years, but have only recently made use of the WP plugin in a client's new website.
http://www.helenenglandphotography.co.uk/wp

I have no problems viewing the galleries throughout the site on any of my pcs or with any browsers.  My client however, who until recently had no problem viewing the galleries is now suddenly getting the 'SimpleViewer requires JavaScript and the Flash Player.' message.

She claims to have both the latest flash player and javascript enabled in her browser (Safari), something which I also got her to check by asking her to visit:
http://www.simpleviewer.net/news/?p=327
and
http://www.simpleviewer.net/simpleviewe … /embedded/

She has no problems viewing the gallery in the second link (an embedded simpleviewer gallery), but can't view the wp plugin gallery example in the first link.

There are no other wordpress plugins installed, and no other scripts employed which may be conflicting.  I'm using a custom wordpress theme, however, this does call the wp_head function (obviously, otherwise the galleries wouldn't be working for me either).

So I'm now confused, at a loss, and hoping this is a silly error that Stephen can help me with!

Re: Galleries not displaying

I have been able to successfully view the gallery (http://www.helenenglandphotography.co.uk/wp) in Firefox 14.0.1, IE9, Chrome 20, Safari 5.1.7 and Opera 12 on my PC.
I suspect the problem lies with your client's browser.

If there was simply a problem with Adobe Flash Player in your client's browser, then the gallery would be displayed by the Mobile Player rather than the Flash Player (but your client would still see a gallery).
It is possible that JavaScript is disabled in your client's browser. This would certainly cause the error message that you have described to be displayed.

The first thing I would do is ask your client to double-check that JavaScript is enabled in her Safari browser ('Preferences -> Security -> Enable JavaScript').
She can then double-check her Adobe Flash Player installation by visiting this page in her browser.
Finally, I would completely clear the browser cache before reloading the gallery to ensure that all pages loaded by the browser are current.

Steven Speirs
SimpleViewer Support Team.

Re: Galleries not displaying

Thank you for your help - unfortunately galleries are still not displaying for my client.

I did think that the problem was with her browser, but after I had already got her to check that there was no problem with flash or javascript I ran out of ideas.

She has confirmed again that JavaScript is enabled ( I have screenshots from her of the security settings with Javascript definitely ticked to show that it is enabled).
I have also had her visit http://javatester.org/javascript.html to confirm that javascript is enabled and she is able to view other javascript effects on sites that I have asked her to view.

I have had her visit the page you suggested to confirm that her Flash Player installation is ok, and she can view the animation of the red ball without any problems.

I have also had her clear the browser cache by doing a full reset of everything in Safari, cache, cookies, etc.

She still can not view any WordPress simpleviewer galleries which have been installed through the Simpleviewer WordPress plugin, whether on her own new website, or on any other websites. 

She can however view simpleviewer galleries outside of WordPress sites and various other instances where flash and/or javascript are employed.

Any other ideas for the cause of this problem would be very welcome.

Re: Galleries not displaying

If JavaScript and Adobe Flash Player are both enabled and the cache is completely empty, then there is no reason that I can think of why your client should be able to view all SimpleViewer galleries other than those embedded in WordPress posts.
Perhaps you could suggest that you client tries to view the problematic galleries in other browsers (such as Google Chrome and Firefox). If she is able to view the galleries in the other browsers, then the problem definitley lies in her Safari browser. If not, then the problem lies elsewhere. It may not definitively diagnose the problem but might help get closer to figuring it out.

Steven Speirs
SimpleViewer Support Team.

Re: Galleries not displaying

Just as an update on the situation, my client has since installed Firefox on her Mac.  She has flash player installed in that browser and javascript is enabled, but she's still unable to view simpleviewer galleries created by the WP plugin.

The problem therefore seems not to be in the Safari browser alone, but something with her Mac that I'm at a loss to explain.  Particularly as she had no problems in viewing the galleries on the same computer for several weeks before the problem appeared.

Re: Galleries not displaying

The only other reason I can think of that would cause a SimpleViewer gallery to not display if is your client is using a 3G connection to access the internet and the provider uses content modification.
If that is the case, then please see this FAQ for details:
Why can't I view my gallery on a 3G mobile connection?

Steven Speirs
SimpleViewer Support Team.