Topic: Background Image does not appear on all browsers

Hello! I used svBuilder Pro for a lovely slideshow using about 40 slides. I chose a nice background photo (as I have in previous slideshows). It shows up nicely on my Safari and also on the few friends' browsers that I asked to view it but the client
(and her sister) cannot see the background image. They are also using Safari. What do you think this can be? I checked to make sure she has updated Flash Player... check. Emptied Cache... check. What else can I do to make sure this background image appears in all browsers all the time. Here is the url: http://roedeanstudiox.com/Collections/F … index.html
Thank you!
Diane

Re: Background Image does not appear on all browsers

For the record, your background image is displayed in your gallery when I view it in Safari 5.1.7 on my PC.

The first thing I would do is double-check that your client and sister have Adobe Flash Player installed and activated in their browsers by visiting this web page: http://helpx.adobe.com/flash-player/kb/ … layer.html
If they do not have Adobe Flash Player installed and activated, then the gallery will be displayed by the Mobile Player which does not support the Background Image options.

Another thing you can try is to use a relative rather than absolute URL for your background image.
Instead of entering http://roedeanstudiox.com/Collections/F … ground.jpg into svBuilder-Pro as your 'Background URL', enter only flower_background.jpg.

Also, I notice that your gallery uses SimpleViewer-Pro v2.2.0.
Try upgrading to the current version (v2.3.0) as many bugs have been fixed since v2.2.0.
Please see the SimpleViewer Version History for details.
For instructions on how to download the current version of SimpleViewer-Pro and upgrade your gallery, please see the Upgrading SimpleViewer-Pro page.

Steven Speirs
SimpleViewer Support Team.

Re: Background Image does not appear on all browsers

Thank you for your reply, Steven, but I did all that you suggested and still nothing. My husband cannot view the background either. He is on a Mountain Lion MAC. I am at my wits end and the client asks me every day when I am going to fix this. Thank you for any help you can give me. Thank you!! Diane




Steven Speirs wrote:

For the record, your background image is displayed in your gallery when I view it in Safari 5.1.7 on my PC.

The first thing I would do is double-check that your client and sister have Adobe Flash Player installed and activated in their browsers by visiting this web page: http://helpx.adobe.com/flash-player/kb/ … layer.html
If they do not have Adobe Flash Player installed and activated, then the gallery will be displayed by the Mobile Player which does not support the Background Image options.

Another thing you can try is to use a relative rather than absolute URL for your background image.
Instead of entering http://roedeanstudiox.com/Collections/F … ground.jpg into svBuilder-Pro as your 'Background URL', enter only flower_background.jpg.

Also, I notice that your gallery uses SimpleViewer-Pro v2.2.0.
Try upgrading to the current version (v2.3.0) as many bugs have been fixed since v2.2.0.
Please see the SimpleViewer Version History for details.
For instructions on how to download the current version of SimpleViewer-Pro and upgrade your gallery, please see the Upgrading SimpleViewer-Pro page.

Re: Background Image does not appear on all browsers

I see your background image when I view your gallery in Firefox 15.0, IE9, Safari 5.1.7, Chrome 21 and Opera 12.0.1 on my PC and see no reason why the background image should not appear on a Mac running Mountain Lion as long as Adobe Flash Player is installed and activated in the browser being used to view the gallery.

One workaround would be to make your gallery's background transparent and to display your background image using HTML and CSS instead of SimpleViewer's own Background Image functionality. In doing so, your background image would be displayed behind the gallery when it is displayed by both the Flash Player and the Mobile Player (which is used to display the gallery on mobile devices and in browsers which do not have Adobe Flash Player installed and enabled).

Remove the backgroundURL entry from your gallery's XML file and use the following as your http://roedeanstudiox.com/Collections/Fall_2012/index.html page:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html>
<head>
    <meta http-equiv="content-type" content="text/html; charset=utf-8">
    <title>SimpleViewer Gallery</title>
    <style type="text/css">
        body {
            background-image: url('http://roedeanstudiox.com/Collections/Fall_2012/flower_background.jpg');
            background-size: cover;
        }
    </style>
</head>
<body>
    <!--START SIMPLEVIEWER EMBED -->
    <script type="text/javascript" src="svcore/js/simpleviewer.js"></script>
    <script type="text/javascript">
    simpleviewer.ready(function () {
        simpleviewer.load('sv-container', '100%', '100%', 'transparent', true);
    });
    </script>
    <div id="sv-container"></div>
    <!--END SIMPLEVIEWER EMBED -->
</body>
</html>
Steven Speirs
SimpleViewer Support Team.

Re: Background Image does not appear on all browsers

Thanks so much, Steven - Will take your advice. Most viewers of this site will be on old, slow PCs I am afraid. Will send you update. So glad you are there for me. -- Diane

Re: Background Image does not appear on all browsers

Thanks so much, steven. That did it!!
I am saving up for Juicebox now!
Diane big_smile