Topic: V2.3.1 Open in New Window Incorrect URL

Sorry if this has been addressed before in which case point me in the right direction?

I have used V1 Pro and have just bought the latest Pro version for a new web site, I have overcome a few issues searching for answers but cannot get the open image in a new window to work....

Everything else seems fine, even the download button, please take a look at http://www.lasalasanpedro.com/2012gallery-opening.html

Is it something to do with the link URL in the XML file?

Thanks

KEVIN

Re: V2.3.1 Open in New Window Incorrect URL

This might be caused by having spaces in your image filenames.
As the image filenames form part of a URL when uploaded to your web server, make sure that the filenames use only web-safe characters.
Please see section 2.3 of this document for details: http://www.ietf.org/rfc/rfc3986.txt

Characters that are allowed in a URI but do not have a reserved purpose are called unreserved. These include uppercase and lowercase letters, decimal digits, hyphen, period, underscore, and tilde.

Steven Speirs
SimpleViewer Support Team.

Re: V2.3.1 Open in New Window Incorrect URL

Hi Steven

Thank you for your quick reply much appreciated as I am working on this now....

I understand what you are saying but this doesn't seem to be the issue, another gallery http://www.lasalasanpedro.com/2012gallery-master.html does not have spaces in the image names and the same problem still exists.

I found a work around in another post and amending the Link URL in the XML file to the full path solves the issue, I just tested the first image in the above gallery.

Before I do a find and replace and change all URLs I just want to know if there is another workaround?

Thanks

KEVIN

Re: V2.3.1 Open in New Window Incorrect URL

I have done some further investigation and this is a known bug whereby relative linkURLs do not work in conjunction with a baseURL. This bug will hopefully be fixed in the next version of SimpleViewer.
Until then, the workarounds are to either:
(1) Define the linkURLs using absolute URLs (rather than relative URLs), or...
(2) If you simply want the 'Open Image' button to open the image displayed in the gallery (i.e. the imageURL and the linkURL would be the same), then you can leave the linkURL empty (linkURL="") or leave out the linkURL attribute completely and SimpleViewer will default to using the imageURL for the 'Open Image' button.

Steven Speirs
SimpleViewer Support Team.

Re: V2.3.1 Open in New Window Incorrect URL

OK understood, I viewed a post from earlier this year that said it was a known bug, just thought it may have been corrected...

Should be able to do a find a replace and add the full URL easily enough rather than deleting the contents of LinkURL.

Thanks again

KEVIN