Topic: Gallery not been showed online - only in my computer

Hello,
i´ve posted this some time ago. I can see the gallery when I start the page from the hard disk, other people see it without problems on their computers, but I do not see it when I go online...
The administrator tried it with many different browsers without problem, so sometime later I just gave up.
I was trying again with Safari and the "Error console" and I receive following error ONLY when seeing it online:

undefined is not an object (evaluating b.toLowerCase)
undefined is not a function (evaluating simpleviewer.ready(simpleviewer.load(HERE MY PARAMETERS))

the website is www.anjasan.com

The code is

<body>
       
          <!--START SIMPLEVIEWER EMBED -->
    <script type="text/javascript" src="svcore/js/simpleviewer.js"></script>
    <script type="text/javascript">
    simpleviewer.ready(function () {
        simpleviewer.load("sv-container", "100%", "100%", "transparent", true);
    });
    </script>
    <div id="sv-container"></div>
    <!--END SIMPLEVIEWER EMBED -->

    </body>

I have seen from some post, people writing the parameters like "100%", an people writing like '100%'. Tried both possibilities without success...

I guess now I have a little more information about it. Does anyone knows what could be? It annoys me much, that it only happens on my computer!!

thanks a lot for your help

Re: Gallery not been showed online - only in my computer

Your gallery displays OK when I view it in all major browsers on my computer and I see no errors in the Error Console when viewing it in Safari.
Try completely clearing your browser's cache before reloading your gallery.
Also, try viewing your gallery in different browsers to see if this makes a difference.

If you are using a 3G connection, please see this FAQ:
Why can't I view my gallery on a 3G mobile connection?

Incidentally, you can use single quotes or double quotes around the parameters in the simpleviewer.load() function.

Steven Speirs
SimpleViewer Support Team.

Re: Gallery not been showed online - only in my computer

thank you for the quick answer!!

I tried with Firefox, and the same :-(
Error console:
TypeError: b is undefined
TypeError: simpleviewer.ready is not a function

Could it be some syntax of the gallery.xml or other archive?!

Re: Gallery not been showed online - only in my computer

It sounds like a JavaScript problem but your gallery works OK in browsers on my computer which is why I thought that perhaps a 3G connection (which is known to break certain JavaScript-based web sites) might be the root of the problem.
It certainly seems to be a problem specific to your own computer/internet connection as others (including myself) have no problem viewing your gallery.

Here are a few things that you can try:

  • Ensure that JavaScript is enabled in your browsers.

  • Try disabling any add-ons and extensions that you may have installed in your browsers.

  • Ensure that you are not conected to the internert via a 3G connection as noted in this FAQ.

  • Try validating your pages with the W3C Markup Validation Service and fix any errors reported.

  • Update your gallery to the latest version of SimpleViewer (v2.3.1) by following the instructions here.

Steven Speirs
SimpleViewer Support Team.

Re: Gallery not been showed online - only in my computer

I´ve checked java, add-ons, etc. and everything is OK

But yes, I am connected over an USB-Stick with a SIM-Card, so I guess that is the reason why I only have the problem.

I will try over Wi-Fi and also use the Stick on other computer to be 100% sure.
Thank you very much for everything, I will here to confirm it.

Re: Gallery not been showed online - only in my computer

But yes, I am connected over an USB-Stick with a SIM-Card, so I guess that is the reason why I only have the problem.

You have a 3G connection and that is, indeed, your problem.

Steven Speirs
SimpleViewer Support Team.

Re: Gallery not been showed online - only in my computer

then I can only wait, until it comes out a new version which solves the problem.
On your FAQ you say,

Most networks add an option to 'Request desktop site' which bypasses the issue.

do you know how could I enable this option on a MAC? I was looking at the configuration of the network but did not find such an option

thanks a lot for the supporting

Re: Gallery not been showed online - only in my computer

I remind me of something!!
we had the same problem with Facebook, and activating something on Facebook we solved the problem.
It was an option called (in german) "sicher durchstöbern durch Facebook", in english it would be something like "secure browsing in Facebook"
may be that helps a little bit, finding a solution

Re: Gallery not been showed online - only in my computer

Please see this forum post by tomzinho who has had success in turning off content modification.
For further support on if and how this can be achieved with your own connection, please contact your 3G provider.

Steven Speirs
SimpleViewer Support Team.

Re: Gallery not been showed online - only in my computer

Thanks Steven.
i just wrote tomzinho in oder to learn how he made it.

Re: Gallery not been showed online - only in my computer

I would recommend contacting your 3G provider directly to find out if content modification can be removed from your account and, if so, how. Each provider's web site, software and controls will be different.

Steven Speirs
SimpleViewer Support Team.