Topic: Cannot upgrade WP-SimpleViewer

I have been at it for a few days now and have not been able to successfully install SimpleViewer 2.3.1 to my Wordpress site. I'm working on a Mac with the most recent updated operating system.

So far I have tried:
1. installing the free plugin on wordpress and then trying to upgrade it. The initial install went fine but the upgrade failed.
The directions in the SimpleViewer support and in this forum are not clear or simple enough for someone like myself with very limited technical skills. Maybe I'm just not comprehending how to do this but I can't find a way to upload or download the pro "svcore" as directed

2. Then I tried - multiple times - to upload the svPRO zip file directly into wordpress. The error message is always the same: upload failure.

I made sure that all previous sv files were removed from my computer and from my trash files. Made no difference.

I really need to get this up and running immediately and hope that someone can walk me through the process.
Thank you so much!
Buffie

Re: Cannot upgrade WP-SimpleViewer

In order to upgrade WP-SimpleViewer from SimpleViewer-Standard (which it comes bundled with) to SimpleViewer-Pro.

  • Log into your web hosting account with an FTP program such as Filezilla

  • Navigate to the 'wordpress/wp-content/plugins/wp-simpleviewer/' directory on your web server

  • Delete the 'svcore' folder from that that directory

  • Unzip the 'simpleviewer_pro_231.zip' file (the SimpleViewer-Pro download package) locally on your computer

  • Navigate to the 'simpleviewer_pro_231/web/' folder within the unzipped archive

  • Upload the 'svcore' folder from the 'simpleviewer_pro_231/web/' folder within the unzipped archive to the 'wordpress/wp-content/plugins/wp-simpleviewer/' directory on your web server using your FTP program

Steven Speirs
SimpleViewer Support Team.

Re: Cannot upgrade WP-SimpleViewer

Any suggestions on how to upgrade WordPress-SimpleViewer 1.5.4 to pro version properly? I have been using the WordPress 3.3.2 and have successfully made galleries using both WP-SimpleViewer v2.3.0 and WP-SimpleViewer v1.5.4, so the plugins are compatible with WordPress 3.3.2. Now I need to upgrade that to its pro version. Would it be possible to handle the upgradation by myself or do I need to seek the help of some professionals? I would like to get the suggestions and pointers from anyone, that could help me out to solve this issue. [Non-relevant link removed.]

Re: Cannot upgrade WP-SimpleViewer

I do not see any evidence of any SimpleViewer galleries on the page whose link you provided.
WP-SimpleViewer v1.5.4 is not compatible with the current version of SimpleViewer-Pro (v2.3.1).
WP-SimpleViewer v1.5.4 uses an older version of SimpleViewer (prior to SimpleViewer being re-written from scratch for v2).
As such, SimpleViewer v2 uses different configuration options and different embedding code (to support Universal Playback) so you can only upgrade WP-SimpleViewer v1.5.4 with SimpleViewer-Pro v1.9 by replacing the Standard 'viewer.swf' file in the plugin's folder with the 'viewer.swf' file from the SimpleViewer-Pro v1.9 download zip package.

Steven Speirs
SimpleViewer Support Team.

Re: Cannot upgrade WP-SimpleViewer

thanks for the reply will try it