Topic: "Gallery XML Not Found" No Gallery Folder?

So, I've been working on this for a few days and spending a lot reading relevant posts to my problem and I just can't figure it out.  I'm finally going to ask.

Please take a look, it says "Gallery XML Not Found"

http://stylingelegance.com/pages/gallery.php

Here is the code I'm using...

<!--START SIMPLEVIEWER EMBED.-->
<p>
<script src="http://www.stylingelegance.com/pages/svcore/js/simpleviewer.js" type="text/javascript"></script>
<script type="text/javascript"><!--
var flashvars = {};
simpleviewer.ready(function () {
simpleviewer.load("sv-container", "600", "700", "FFFFFF", true, null, null, null, false);
});
// --></script>
</p>
<!-- END SIMPLEVIEWER EMBED -->

When I look in the folder, I do not see a file that says "gallery.xml".  From reading some of the posts here it seems as if I'm supposed to have that file.

Would really appreciate the help.

Thanks,
Taylor

Re: "Gallery XML Not Found" No Gallery Folder?

Please take a look, it says "Gallery XML Not Found"

Please see this FAQ: When I view my gallery I see the message 'Gallery XML Not Found'. How do I fix this?

You have two different lots of embedding code on your page, both trying to embed a gallery into the same container.

The problem with the first gallery is that it uses the code:

<script src="http://stylingelegance.com/mygallery/svcore/js/simpleviewer.js" type="text/javascript"></script>

... but the file 'simpleviewer.js' does not exist in that location on your web server. Check that your 'mygallery' folder has been uploaded to the root of your web space.

When I look in the folder, I do not see a file that says "gallery.xml".  From reading some of the posts here it seems as if I'm supposed to have that file.

Every SimpleViewer gallery must have an XML file which, by default, should be named 'gallery.xml' and should be located in the same folder as the HTML page which contains the embedding code.
If you create a gallery with svBuilder-Pro, your gallery folder will contain a file named 'gallery.xml' which contains the configuration options for the gallery and lists the images to be displayed.
If you have renamed or moved your gallery's XML file, you can point SimpleViewer towards it using the galleryURL configuration option.

Steven Speirs
SimpleViewer Support Team.

Re: "Gallery XML Not Found" No Gallery Folder?

Hi Steven, I really appreciate such a prompt reply.  I had made so many mistakes, I'm embarrassed to have posted.  You helped me to figure out where I was REALLY wrong but I'm still doesn't work, now it doesn't even say "Gallery XML Not Found"

Here is the new link...

http://stylingelegance.com/pages/testgallery.php

Here is the new code...

<!--START SIMPLEVIEWER EMBED.-->
<p>
<script src="http://www.stylingelegance.com/pages/gallery/svcore/js/simpleviewer.js" type="text/javascript"></script>
<script type="text/javascript"><!--
var flashvars = {};
flashvars.baseURL = "http://www.stylingelegance.com/pages/gallery/";
flashvars.galleryURL = "http://www.stylingelegance.com/pages/gallery/gallery.xml";
simpleviewer.ready(function () {
simpleviewer.load("sv-container", "600", "700", "FFFFFF", true, null, null, null, false);
});
// --></script>
</p>
<!-- END SIMPLEVIEWER EMBED -->

Here is an image of how it is all uploaded in my FTP space.

http://www.stylingelegance.com/images/ftp.jpg

If I click on this link it works.  But of course it's not how I want it.  I want it embedded in my web site.  I thought it might be useful to show you.

http://www.stylingelegance.com/pages/gallery/

I have tried to correct all the mistakes and hopefully I've made it easier for you to help me.  I really appreciate the time you're taking to help me with this.

Thanks,
Taylor

Re: "Gallery XML Not Found" No Gallery Folder?

Your embedding code does not take into account the 'flashvars' that you have set.
The 'flashvars' should be the 6th parameter in the simpleviewer.load() line.
Change:

simpleviewer.load("sv-container", "600", "700", "FFFFFF", true, null, null, null, false);

... to:

simpleviewer.load("sv-container", "600", "700", "FFFFFF", true, flashvars, null, null, false);

Please see the Embed Code Parameters section of the SimpleViewer Embedding Guide for details.

Also, if setting a baseURL and your gallery's XML file is named 'gallery.xml' and is located in the baseURL folder, then there is no need to set a galleryURL as well.

Steven Speirs
SimpleViewer Support Team.

Re: "Gallery XML Not Found" No Gallery Folder?

Thank you for your help.  I finally got it working with your help.  I'm so relieved.  I bought the program and  I had two clients also buy it thinking it would be a lot easier than it was, so I had to follow through.  I'm glad I did.  It looks great.