Topic: Front Page Gallery

Hi,

I have built my gallery using SV Builder Pro and need to paste some code into the page. Could you tell me what piece of code I need to add, because I am not having any luck with any of them.

Thanks

Re: Front Page Gallery

For years I have used Simpleviewer to add a gallery to a Microsoft Front Page website without any problem. I now have SV Builder Pro for creating a new gallery but, whatever I do, I can't get it to look right on the page. Does a SV Builder Pro creation not  work properly on a FP website page?

Re: Front Page Gallery

The embedding code that svBuilder-Pro provides on the 'Publish' tab is valid HTML and should work in any web page.
Instructions for using the code provided by svBuilder-Pro to embed a gallery in a web page can be found here.

Once you have inserted the embedding code in your web page, you can check the validity of your complete web page using the W3C Markup Validation Service and fix any errors reported. Once your page validates, it should be rendered with greater predictability and consistency between different browsers.

If you continue to experience difficulties, please post the URL to your gallery so that I can take a look and help further.

Steven Speirs
SimpleViewer Support Team.

Re: Front Page Gallery

I have created and added the gallery again, uploaded it to the website and added the embedding code to the page I want it displayed, but nothing shows up.

I can't see how I'm supposed to point the code to the installed gallery - there is no image/thumbnail path in the gallery xml any more.

Re: Front Page Gallery

I have created and added the gallery again, uploaded it to the website and added the embedding code to the page I want it displayed, but nothing shows up.

Please post the URL to the web page containing your gallery so that I can take a look and help further.

I can't see how I'm supposed to point the code to the installed gallery

If following the embedding instructions here, the gallery files (from inside the gallery folder) should be uploaded to the same directory as the web page containing the embedding code.
If you have uploaded your complete gallery folder to a different location on your web server, you can embed the gallery by using the baseURL method documented here.

there is no image/thumbnail path in the gallery xml any more.

That is correct. The paths to the thumbnails and images are individually defined in the corresponding thumbURL and imageURL entries.

Steven Speirs
SimpleViewer Support Team.

Re: Front Page Gallery

This is where I get confused. I have added the embedding code to the page I want the gallery, but I'm not sure where to put the second piece of code. The URL is http://www.libraimages.co.uk/pictures.htm

Re: Front Page Gallery

I eventually figured it out - many thanks for your help.

Re: Front Page Gallery

I am glad you have figured it out.
Thank you for posting back to let me know.

Steven Speirs
SimpleViewer Support Team.

Re: Front Page Gallery

I'm afraid I'm back where I started. I uploaded all the gallery files to the same directory as the web folder and the gallery works fine, but it defaults straight to the gallery, and not the homepage anymore.

Re: Front Page Gallery

It sounds like your own home page may have been named 'index.html' and you have overwritten this with the gallery's own 'index.html' page.
If embedding the gallery in an existing web page alongside other content, then you do not need the gallery's own 'index.html' page. It is used only to display the gallery on its own.
Otherwise, you could keep all the gallery files separate from your other web site files by keeping the gallery in its own folder and embedding it in your web page using the baseURL method documented here.

Steven Speirs
SimpleViewer Support Team.

Re: Front Page Gallery

I really don't know what to do now. I removed all the files that I had taken out of the gallery folder and added the second piece of code to the pictures.htm page and now my whole website is a complete mess.

Re: Front Page Gallery

I've added the gallery again to the page using the second code, but something's going wrong. Could you please tell me where I'm going wrong?

Re: Front Page Gallery

Hi Steven - sorted at last!

Many thanks,

John