Topic: Gallery XML not found after upgrading to Wordpress 3.5.2

We just updated our Wordpress site to the latest version, and now we are getting the "Gallery XML not found" message on each page where a gallery is installed. All .xml files are in the upload folders though, and the upload folder has write permissions. The site is using the latest version of SimpleViewer Pro.

The other problem that we are encountering after the upgrade is the following:

On the Edit Page screen, when we click the Add Media button, the list of the photos in a certain order attached to the page doesn't get displayed anymore. Instead, all images from all the pages are displayed in random order.

Also when I click the icon to add a gallery on a page, I get the following error:

Forbidden
You don't have permission to access /wp-content/plugins/wp-simpleviewer/sv-config.php on this server.

Thank you in advance for your help.

M.

Last edited by missyp (2013-02-07 19:06:22)

Re: Gallery XML not found after upgrading to Wordpress 3.5.2

We just updated our Wordpress site to the latest version, and now we are getting the "Gallery XML not found" message on each page where a gallery is installed.

The current version of WP-SimpleViewer (v2.3.2) has been tested with (and is compatible with) the latest version of WordPress (3.5.1).
Updating WordPress itself should not alter the XML files (in the 'wp-content/uploads/' directory) or the plugin's own code (in the 'wp-content/plugins/wp-simpleviewer/' directory) which provides the 'svcore' folder and generates the embedding code. These are essentially the only two components that are responsible for displaying a gallery.
Perhaps something else has changed on your web server to result in the error message you are seeing.

On the Edit Page screen, when we click the Add Media button, the list of the photos in a certain order attached to the page doesn't get displayed anymore. Instead, all images from all the pages are displayed in random order.

This has nothing to do with WP-SimpleViewer at all. The uploading and image ordering process within the Media Library is handled entirely by WordPress. At the time the gallery is displayed, WP-SimpleViewer simply looks for the images attached to the post and displays them in the order in which they are given to WP-SimpleViewer by WordPress.
You should be able to reorder images in a gallery by doing the following:

  • Edit the post containing the gallery

  • Click the 'Add Media' button

  • Go to the 'Insert Media -> Media' section

  • Select 'Uploaded to this post' from the drop-down menu

  • Drag and drop the images into your chosen order

  • Close the 'Add Media' window

Also when I click the icon to add a gallery on a page, I get the following error:

Forbidden
You don't have permission to access /wp-content/plugins/wp-simpleviewer/sv-config.php on this server.

Double-check the permissions of all directories on your web server.
It sounds like permissions may be the root of both the 'Gallery XML not found.' message and the 'Forbidden' error.

If you are using the BulletProof Security plugin, please see this forum post for a suggestion.

Steven Speirs
SimpleViewer Support Team.

Re: Gallery XML not found after upgrading to Wordpress 3.5.2

Hi, my client has been using WP-simpleviewer 2.2 with the pro version (2.2) without a problem.

  • I upgraded the website to Wordpress 3.5.1. All galleries were working perfectly.

  • Then I updated the WP-simpleviewer plugin automatically, and the galleries worked great, albeit with the Simpleviewer link.

  • Then I downloaded the latest pro-version 2.3.1, and ftp'd the svscore folder across. After that, I got the same error message on all galleries :-(

  • I deactivated each plugin one at a time, but that didn't make a difference.

  • I've since reverted to the earlier versions of WP-simpleviewer (2.2) and the pro svscore (2.2) and it's working beautifully again. I haven't changed anything else.

For your reference, here's a link to one of the galleries: http://marie-josevanrijsbergen.nl/portf … an-berlijn

Any ideas? Thanks and kind regards, Victoria

Last edited by marvicbiz (2013-02-08 13:24:55)

Re: Gallery XML not found after upgrading to Wordpress 3.5.2

I have just tried to reproduce the problem you describe by following the steps you listed.
In WordPress 3.5.1, I installed WP-SimpleViewer v2.2.0, created a gallery, updated the plugin automatically to v2.3.2 and replaced the 'svcore' folder in the plugin with the v2.3.1 Pro version. All worked as expected and my gallery displays correctly.

Then I downloaded the latest pro-version 2.3.1, and ftp'd the svscore folder across. After that, I got the same error message on all galleries :-(

Upgrading a gallery's 'svcore' folder should not cause the 'Gallery XML not found.' message to be displayed.
I would try reinstalling the plugin (and Pro 'svcore' folder) to ensure that all WP-SimpleViewer files are present and correct.
Try manually deleting the entire 'wp-simpleviewer' folder from your 'plugins' directory, download the latest version of WP-SimpleViewer from this page, extract the zip file, replace the 'wp-simpleviewer/svcore/' folder with the v2.3.1 Pro version and upload the 'wp-simpleviewer' folder to your 'plugins' directory.

Steven Speirs
SimpleViewer Support Team.