Topic: 'TiltViewer requires flash player - go here to install' Problem

Hi everyone,

I seem to be having a problem with TiltViewer that I just can't seem to figure out.. I hope someone here can help me! smile

I Googled the hell out of this problem but although I got back a lot of people having the same troubles and a million suggestions for what it may be, I've not found a solution and I need to get it fixed asap.

I have incorporated TiltViewer into my site under a gallery page and all works fine offline, all files are in the right place, all my code works fine and the gallery has no problems at all. When I upload it to my server however, the page shows that Flash Player needs to be installed.

I have checked that I have both the most recent version of Flash installed (all browsers) and that Javascript is enabled in all of them. I've tried it across all browsers and gotten friends to test it on their computers so I'm sure it's not a browser problem or that something isn't installed / set correctly. I've also tried making sure all relevant files are uploaded including the .js file, and have tried moving them round the root folders but with no change.

I manage my site through FileZilla.

Any help would be appreciated! smile Cheers in advance!

PS: I know similar topics are up already but couldn't really find one that answered my question so hope it's OK to have opened a new thread smile

Re: 'TiltViewer requires flash player - go here to install' Problem

Please see the FAQs here.
The first one deals with the question "When I view my gallery I see the message 'TiltViewer requires the Flash Player', even though I have Flash installed."
If this does not help (and it sounds like you may have already tried the suggestions in the FAQ), then please post the URL to your gallery so that I can take a look.

Steven Speirs
SimpleViewer Support Team.

Re: 'TiltViewer requires flash player - go here to install' Problem

Hi Steven

Thanks for the quick reply, sorry it took a few days to get back on here. I have been through the FAQ and the options they have posted there a few times but with no luck unfortunately sad

My site can be found here, the gallery should display when the 'Design' tab is clicked: http://katiepeplowdesign.co.uk/

Thanks in advance, any help would be much appreciated!!

Re: 'TiltViewer requires flash player - go here to install' Problem

All the code within your gallery's 'index.html' page here: http://katiepeplowdesign.co.uk/designGallery/index.html
... is on a single line with no line feeds to separate the lines of code.
The first comment in the JavaScript code is likely to be commenting out all the remaining JavaScript code on the page.
Place each line of code on an individual line with a line feed/carriage return at the end and your gallery should display OK.

Steven Speirs
SimpleViewer Support Team.

Re: 'TiltViewer requires flash player - go here to install' Problem

Thanks so much Steve, I'll give that a go and see if that works smile