Topic: Problem after Juicebox 1.3.1 update

Hello!

I updated my my Juicebox Pro galleries in svManager to 1.3.1. Now I have problems with editing the galleries with svManager.

I can log in to svManager normally. When I click "Edit" or "Rebuild" in the gallery list one of the galleris I got following problem:

Fatal error: Call to a member function getRgba() on a non-object in /home/kareinen/public_html/svmanager/plugins/juicebox/jbgallery.php on line 415

Any ideas how to fix this? Galleries are working perfectly on the homepage:
http://www.kareinen.fi/svmanager/huonekalut/#1

Re: Problem after Juicebox 1.3.1 update

I found that "Edit" is functioning normally when I delete "languageList" function from the config.xml file.

I had following:

 languageList= "Näytä esikatselukuvat|Piilota esikatselukuvat|Laajenna kokoruutuun|Sulje kokoruututila|Avaa kuva uudessa ikkunassa|Seuraava|Edellinen|Soita musiikki|Pysäytä musiikki|Näytä tiedot|Piilota tiedot|Aloita näytös|Pysäytä näytös|Näytös päällä|Näytös suljettu|Mene takaisin|Osta tämä kuva|Jaa: Facebook|Jaa: Twitter|Jaa: Google+|Jaa: Pinterest|Jaa: Tumblr|of"

I have those scandinavian letters "ä" and "ö" in the translation. Juicebox PRO wasn't showing them normally in the website. When I changed the whole list to following the problem disappeared:

languageList= "Näytä esikatselukuvat|Piilota esikatselukuvat|Laajenna kokoruutuun|Sulje kokoruututila|Avaa kuva uudessa ikkunassa|Seuraava|Edellinen|Soita musiikki|Pysäytä musiikki|Näytä tiedot|Piilota tiedot|Aloita näytös|Pysäytä näytös|Näytös päällä|Näytös suljettu|Mene takaisin|Osta tämä kuva|Jaa: Facebook|Jaa: Twitter|Jaa: Google+|Jaa: Pinterest|Jaa: Tumblr|of"

Re: Problem after Juicebox 1.3.1 update

I wasn't able to reproduce this problem using your first language string. So I don't know why it happened for you.

Anyway, are you ok now?

jack

Jack Hardie
SimpleViewer Support Team.

Re: Problem after Juicebox 1.3.1 update

Yep, I'm ok now.

Maybe the problem is with the server? If I remember correctly I have had some problems with scandinavian  letters before with some other software.