Topic: trouble with embed and joomla

Hello, I built my site on joomla on which I loaded my galleries with the function " iframe ". It works very well on desktop computers but not on IPad nor IPhone.
I try to change method with the embed code but it does not work.
All my galleries are placed in the root of my site.
I give the good path for the file svcore and gallery.xml.
When I open the page on Web I see the progress bar of load but the page remains white:
You can see the resultat on this page:
http://www.brs-photographiste.com/index.php/cosmetique

Here is the code which I entered the article joomla:

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="http://www.brs-photographiste.com/simpleviewer_cosmetique/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars = {};
flashvars.galleryURL = "http://www.brs-photographiste.com/simpl … allery.xml";
simpleviewer.ready(function () {
simpleviewer.load("sv-container", "950", "570", "FFFFFF", true, flashvars, null, null, null, false);
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->

Your assistant would be me of a big help because I do not find the answer in the forum.
Thank you

Re: trouble with embed and joomla

Your simpleviewer.load() line has too many Embed Code Parameters.
Change:

simpleviewer.load("sv-container", "950", "570", "FFFFFF", true, flashvars, null, null, null, false);

... to:

simpleviewer.load("sv-container", "950", "570", "FFFFFF", true, flashvars, null, null, false);
Steven Speirs
SimpleViewer Support Team.

Re: trouble with embed and joomla

Thank you Steven for your answer, I change the code, it doesn't work.

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="http://www.brs-photographiste.com/simpleviewer_cosmetique/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars = {};
flashvars.galleryURL = "http://www.brs-photographiste.com/simpl … allery.xml";
simpleviewer.ready(function () {
simpleviewer.load("sv-container", "950", "570", "FFFFFF", true, flashvars, null, null, false);
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->

Re: trouble with embed and joomla

Your gallery is actually embedded correctly but displays white crosses (where images should be) on a white background so you cannot see the problem.
The problem is that the imageURLs and thumbURLs in your gallery's XML file are defined using relative paths and they should be relative to the web page containing the embedding code but they are currently relative to the XML file.
As you have uploaded your complete gallery folder to your web server, then, rather than change all the paths in the XML file, you can simply use a baseURL rather than a galleryURL by changing the line:

flashvars.galleryURL = "http://www.brs-photographiste.com/simpleviewer_cosmetique/gallery.xml"; 

... to:

flashvars.baseURL= "http://www.brs-photographiste.com/simpleviewer_cosmetique/"; 

For reference, the baseURL method of embedding is documented here.

Steven Speirs
SimpleViewer Support Team.

Re: trouble with embed and joomla

Hello,
I followed your advice by using baseURL rather that GalleryURL. I had already tried this method but unsuccessfully.
I discourage to find a solution, me does not understand where from comes the problem. Why it does not work?????

Re: trouble with embed and joomla

Finally, it works.

With the modifications that you gave me, I have rewrite the code:

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="http://www.brs-photographiste.com/simpleviewer_cosmetique/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars = {};
flashvars.baseURL = "http://www.brs-photographiste.com/simpl … osmetique/";
simpleviewer.ready(function () {
simpleviewer.load("sv-container", "950", "570", "FFFFFF", true, flashvars);
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->

And the gallery displays.
I have no necessary equipment for verified if that works on the mobile devices.

Thank you for your assistant.

Re: trouble with embed and joomla

I have no necessary equipment for verified if that works on the mobile devices.

I can confirm that your gallery at http://www.brs-photographiste.com/index.php/cosmetique displays and functions fine in Mobile Safari on an iPod Touch.

Steven Speirs
SimpleViewer Support Team.