Topic: Grreek languageCode

Hello there,

after blowing my mind trying more than other 10 gallery WP pluggins.
i installed  SimpleViewer v2.3.1 in wordpress 3.5.1, and I must say that iam impressed from speed ! and light skin interface, and resize quality and.. and... Except Greek language image captions and titles. Not working. Instead of fonts, i see some square shapes

So i am just about to purchase pro version, but before that , i need to be sure , that either caprions or gallery title, could
be in Greek language.

Thank you, and well done for your great job !

Re: Grreek languageCode

The current version of WP-SimpleViewer (v2.3.2.1) should handle Greek text fine in both the gallery title and image captions.
I have just tried it for myself in a test gallery and it works well in WordPress v3.5.1.
Please post the URL to your gallery so that I can take a look and investigate further. Thank you.

Steven Speirs
SimpleViewer Support Team.

Re: Grreek languageCode

Thank you for answering.

Site link is: http://www.safeliving.gr/gallery/
by clicking any of the  posts you could see about.

Re: Grreek languageCode

The link you provided goes to a 'website under construction' page.
There are no links to any other pages or galleries.

Steven Speirs
SimpleViewer Support Team.

Re: Grreek languageCode

Yes you are correct.

We just publish our new site 3 hours before.
Please follow that  http://www.safeliving.gr/gallery/   link again. It is now working !!
note: In only Google Chrome browser, greek fonts are displaying correct.

Thanks again

Re: Grreek languageCode

and something else,

is pluggin compatible with iphone or ipad devices ?

Re: Grreek languageCode

Your Greek text looks OK in your galleries (in both the gallery titles and the image captions) in Firefox 21, Chrome 27, IE10 and Safari 5.1.7 on my PC.
Perhaps there is a setting in your browser which is preventing your text from being displayed correctly.
Check the font and encoding settings in your browser's settings.

is pluggin compatible with iphone or ipad devices ?

Yes. WP-SimpleViewer includes the latest version of SimpleViewer-Standard (v2.3.1) which features Universal Playback whereby the gallery will be displayed by the Mobile Player (rather than the Flash Player) on mobile devices and in browsers which do not have Adobe Flash Player installed and enabled.

Steven Speirs
SimpleViewer Support Team.

Re: Grreek languageCode

Hello again Steven,

Unfortunatelly for me, even if i have tried almost everything (create again galleries, change encoding
in both of Firefox (21.0 ver) and Explorer (ver 10.0.9200), trying in diferent computers , all results are the same.
No Greek fonts.
note 1: i tried to find gallery.xml, in my FTP folder, but there are only .php files, no xml files.

I even create a new gallery using svBuilder

( <?xml version="1.0" encoding="UTF-8"?>
<simpleviewergallery
    resizeOnImport="false"
    useFlickr="false"
    cropToFit="false"
    title="πορτες"                            )

All results are ...no Greek. (except Ghrome of course 27.0 ver).
About encoding in browsers, i tried   unicode(UTF-8) or GREEK(ISO-88597) or GREEK(WINDOWS-1253).
In all browsers , no change, in Chrome .. no change too(shows Greek, no matter encoding)

Maybe I am not so lucky after all.

Thank you

Re: Grreek languageCode

note 1: i tried to find gallery.xml, in my FTP folder, but there are only .php files, no xml files.

This is OK. As you are using WP-SimpleViewer, the gallery's XML file is generated dynamically when the gallery is displayed (not when it is created).

Try the following:
(1) Open up the following two plugin files in a plain text editor:

wp-simpleviewer/gallery.php
wp-simpleviewer/wp-simpleviewer.php

(2) Search for every instance of new DOMDocument() and replace each with new DOMDocument('1.0', 'UTF-8')
(There should be 2 instances in 'gallery.php' and 7 instances in wp-simpleviewer.php.)
(3) Upload the modified files to their original locations on your web server (overwriting the original files) and try creating a new gallery with Greek text to see if this helps.

Steven Speirs
SimpleViewer Support Team.

Re: Grreek languageCode

I follow your instructions ! and i created 2 new galleries.
No luck, still the same in my browsers.
But let me ask you something . You have mentioned that in your computer and in all browsers , Greek fonts were fine.
But your windows installation is in English. True ?
If so , then problem might be in local Regional settings.
I wll try to check for it and i will inform you about !!

Yannis

Re: Grreek languageCode

OK, it is not ment to be !!

I change regional settings, put everything in English, and still nothing.

It is a pity for me an for you i think.

But thank you for your support ...


PS: Could PRO version  had a better behaviour in Greek fonts ?

Re: Grreek languageCode

I follow your instructions ! and i created 2 new galleries.
No luck, still the same in my browsers.

I see no difference when viewing your web pages (your Greek text still displays correctly) but when I view your dynamically generated XML files (via a browser's 'View Source' functionality), I now see your Greek text rather than encoded characters.

But your windows installation is in English. True ?

That is correct.

PS: Could PRO version  had a better behaviour in Greek fonts ?

There would be no difference between SimpleViewer-Standard (the free version) and SimpleViewer-Pro with regard to your problem.

As I can see your Greek text in all browsers I have tried (and as you can see the Greek text in Chrome), your web site itself seems to be OK and the problem seems to be specific to the other browsers that you use.

Steven Speirs
SimpleViewer Support Team.