Topic: SimpleViewer gallery renders in non-Flash mobile format in I.E. 10?

I am wondering why the SimpleViewer photo galleries that I have made look normal in these browsers: Opera, Safari, Chrome and Firefox, but look like the non-Flash mobile rendering style in Internet Explorer 10?   Please help if you know the answer, thank you.

Re: SimpleViewer gallery renders in non-Flash mobile format in I.E. 10?

It sounds like you do not have Adobe Flash Player installed and enabled in your IE10 browser.
IE10 requires a different (ActiveX) Adobe Flash Player installation than other (plugin) browsers.
Visit this web page in your IE10 browser to check whether or not Adobe Flash Player is installed.

Steven Speirs
SimpleViewer Support Team.

Re: SimpleViewer gallery renders in non-Flash mobile format in I.E. 10?

Steven Speirs wrote:

It sounds like you do not have Adobe Flash Player installed and enabled in your IE10 browser.
IE10 requires a different (ActiveX) Adobe Flash Player installation than other (plugin) browsers.
Visit this web page in your IE10 browser to check whether or not Adobe Flash Player is installed.

Thanks Steven, that was the issue, I installed the Flash player and it now works.  I was wondering though now it seems the stage padding renders differently in IE 10 than in all the other browsers, i.e. it seems to have much more padding above and below the main image, forcing people to have to scroll to see the whole page, where as with the other browsers the padding is normal and no scrolling is needed?

Re: SimpleViewer gallery renders in non-Flash mobile format in I.E. 10?

gordonwilson wrote:
Steven Speirs wrote:

It sounds like you do not have Adobe Flash Player installed and enabled in your IE10 browser.
IE10 requires a different (ActiveX) Adobe Flash Player installation than other (plugin) browsers.
Visit this web page in your IE10 browser to check whether or not Adobe Flash Player is installed.

Thanks Steven, that was the issue, I installed the Flash player and it now works.  I was wondering though now it seems the stage padding renders differently in IE 10 than in all the other browsers, i.e. it seems to have much more padding above and below the main image, forcing people to have to scroll to see the whole page, where as with the other browsers the padding is normal and no scrolling is needed?

I figured out the padding problem in IE 10, it had to do with the embed code, when set to size to=100% it looks bad in IE 10, but fine in other browsers, but if i set the size to the div container in h x w pixels it renders correctly in IE 10, thanks for all your help.

Re: SimpleViewer gallery renders in non-Flash mobile format in I.E. 10?

When setting your gallery's height as a percentage, you should check that all parent containers of your gallery have heights explicitly set via CSS (as noted in this FAQ).
Also, please see the Using Percentage Heights note in the SimpleViewer Embedding Guide.

I am glad that you have resolved your problem.
Thank you for posting back to let me know.

Steven Speirs
SimpleViewer Support Team.