Topic: Bground color and title not updating in gallery managed by svManager

Hi -

I'm having an odd problem where the background color and the gallery title do not update from the customize tab in svManager, but everything else seems to work normally. This is a gallery that was originally created with JB v1.3.0 on my PC. svManager is 1.8.5. Other options from that tab appear to work and Pro features function normally. That background defaults to medium grey, however and titles do not update at all.

Thanks...

Re: Bground color and title not updating in gallery managed by svManager

Could you post a link to the gallery so I can take a look?

jack

Jack Hardie
SimpleViewer Support Team.

Re: Bground color and title not updating in gallery managed by svManager

jack wrote:

Could you post a link to the gallery so I can take a look?

jack

Could I email link to you privately?

Re: Bground color and title not updating in gallery managed by svManager

Sure – you can email me via the forum – just click on my name shown on the left of this post.

jack

Jack Hardie
SimpleViewer Support Team.

Re: Bground color and title not updating in gallery managed by svManager

Your config.xml has backgroundColor="rgba(82,70,64,1)"

The embed code in your index.html has backgroundColor: 'rgba(82,70,64,.1)'

Which one are you trying to achieve?

jack

Jack Hardie
SimpleViewer Support Team.

Re: Bground color and title not updating in gallery managed by svManager

Currently the background color in the gallery is displaying in Chrome and Thunderbird as the default grey (117, 117, 118). I'm just trying to manage the gallery background color and the title through svManager; the Pro options work but not the these basic options. It appears the other options from "basic" work so I'm at a loss as to what's happening.

Thanks

Re: Bground color and title not updating in gallery managed by svManager

The background color is normally set in the embed code in your gallery index file.

When you create or import a gallery in svManager it copies an index.php file into your gallery folder. It seems you are using the index.html from Builder not the index.php created by svManager. This is ok but it does mean that svManager loses control of the embed code.

Look at the source code of your index.html file. The embed code looks like this:

new juicebox({
  containerId : 'juicebox-container',
  galleryWidth: '100%',
  galleryHeight: '100%',
  backgroundColor: 'rgba(82,70,64,.1)'
});

rgba(82,70,64,.1) will give you a pale grey which is what I'm seeing in the gallery.

Try changing the color in your index.html file. Or re-import the gallery and use the svManager index.php file.

jack

Jack Hardie
SimpleViewer Support Team.

Re: Bground color and title not updating in gallery managed by svManager

Thanks this explains the problem. I was editing the background color in the config.xml file and I should instead have been changing it in the index.html file.