Topic: back button URL problem

"Back button text" shows up in the gallery as it should but no matter what I put in the "back button URL" box the link doesn't work.  I  want it to return to my main site's "index.html".  I've tried absolute and relative URLs.  I've "x"ed the text box many times (so it shows up "null") and tried different variations on the URL.  I've saved and published the gallery many times but nothing works.  Any suggestions?

Re: back button URL problem

If using an absolute URL, make sure it starts with 'http://' (e.g. http://www.example.com rather than just www.example.com).
Also, make sure that there are no elements on your web page which are obscuring/overlapping your gallery's Back Button rendering it non-functional.

If you continue to experience difficulties, please post the URL to your gallery so that I can take a look.

Steven Speirs
SimpleViewer Support Team.

Re: back button URL problem

"If using an absolute URL, make sure it starts with 'http://' (e.g. http://www.example.com rather than just www.example.com)."

Tried it both ways and neither works.

"Also, make sure that there are no elements on your web page which are obscuring/overlapping your gallery's Back Button rendering it non-functional."

It's a very simple site with only two pages and the gallery, so I don't think there's anything obscuring/overlapping the SV back button but I'm open to suggestions as to what to look for and where.

"If you continue to experience difficulties, please post the URL to your gallery so that I can take a look."

www.fourthline.ca
click on photography gallery

As you'll see, the "exit gallery" link goes to my host's error page.  At that point, the local path to the index file has somehow been added to the end of the URL.  I'm not putting the local path in the SV "back button URL" box, just the absolute URL.  The local path seems to be getting automatically added but I can't figure out how to stop it from doing this.

Re: back button URL problem

Your gallery's backButtonURL currently points to a location on your own computer's hard drive (resulting in an error 404 page when your gallery is uplaoded).
In your gallery's XML file: http://www.fourthline.ca/SV%20Gallery/gallery.xml
... is the entry:

backButtonURL="/Users/MarkHamilton/Desktop/MH Data/Fourthline Website 2013/index.html"

svBuilder-Pro will use whatever you paste or type into the backButtonURL field in the interface.
Entering "http://www.fourthline.ca/" should work fine.
As an alternative to using svBuilder-Pro, you could open the 'gallery.xml' file in a plain text editor and modify the backButtonURL entry manually.

Steven Speirs
SimpleViewer Support Team.