Topic: SimpleViewer and WPML

Hi all,

i'm working on a site, installing multi language plugin WPML. Now the site also has the SimpleViewer plugin but it won't let me add a gallery to the english translation of the site. I seem to ge the message 'No images specified in Gallery XML'.

It does work on the dutch page: http://www.schaakstukkenmuseum.nl/?page_id=48
But not on the english page: http://www.schaakstukkenmuseum.nl/?page … mp;lang=en

I use Wordpress 3.6 and simpleviewer 2.3.2.1

The images are loaded from the media library. I even tried to load the dutch version from the media library and the english version from Flickr, so two different versions. It won't work somehow.

Anybody has any idea?

Re: SimpleViewer and WPML

Each of your pages load different galleries.
The Dutch page has a Gallery Id of 1 and its XML file contains many images.
The English page has a Gallery Id of 5 and its XML file contains no images at all.
Check in your Media Library to make sure that you have images attached to the English page containing Gallery Id 5.

Steven Speirs
SimpleViewer Support Team.

Re: SimpleViewer and WPML

Hi Steven,

You are right, I noticed the same thing. I followed the steps listed on the website. I thought it's kinda strange to "Close the media window using the cross at the top right (do not click 'Insert into post' or 'Create a new gallery')."

However, how can I check if I have the media attached to that page? In the media Library it only lists the dutch page, so obviously it isn't attached...? Or does it just show one page in the media library?

Can I load the same gallery in different pages? Because that would also be a solution for me. I tried to copy "[simpleviewer gallery_id="1"]" but that didn't work.

Re: SimpleViewer and WPML

I thought it's kinda strange to "Close the media window using the cross at the top right (do not click 'Insert into post' or 'Create a new gallery')."

This is because all you need to do is attach the images to the post. You are not looking to display the images in the post ('Insert into post') outside the gallery.

how can I check if I have the media attached to that page?

If you go to 'Media -> Library' from the WordPress Dashboard, all Media items are listed. The post that each Media item is attached to is listed under the 'Uploaded to' column.

Can I load the same gallery in different pages?

No. The post id (which is used to fetch the attached images) is stored in the gallery's XML file (in the 'wp-content/uploads' folder). Only one post id is stored per gallery.
The easiest thing to do would be to edit the post containing Gallery Id 5, click the 'Add Media' button, upload the images you would like to be displayed in the gallery, close the media window and click 'Update'.

Steven Speirs
SimpleViewer Support Team.

Re: SimpleViewer and WPML

I uploaded the photo's and that seemed to do the trick. Initially I tried to add the media that were already in the library. Maybe that caused the problem? No idea, it worked out now anyway. Thanks for your help!