Topic: Captions with hyphens get a slash added

I noticed that when my captions have quotation marks in them or apostrophes (entered when editing the gallery with NextGEN) and maybe other "special" characters, the caption on WP-Simpleviewer has a slash added. For example, the caption "What's that" might be replaced with "What\'s that". It would be great if you could fix this!

Re: Captions with hyphens get a slash added

It sounds like your web server's PHP installation may have magic quotes turned on. Please see the Disabling Magic Quotes page and try turning off magic quotes to see if this solves the problem.

Steven Speirs
SimpleViewer Support Team.

Re: Captions with hyphens get a slash added

Thanks Steven, that sounds like a reasonable explanation. I tried both the .htaccess solution and php.ini and neither has worked so far. It seems the .htaccess will not work on Bluehost, since it is run as CGI (whatever that means). I also tried php.ini, but I read that that file specifies settings per directory (with no inheritance to sub-folders), so I'm wondering which folder is the key folder that I should put the php.ini in? I tried public-html and wp-content, but no luck.

Re: Captions with hyphens get a slash added

If you are having trouble changing a setting (such as the magic quotes directive) in your web server's 'php.ini' file (or do not have direct access to it), please contact your web host who should be able to help further.
(Creating your own custom 'php.ini' file and placing it in a directory or your choice will not work.)

Steven Speirs
SimpleViewer Support Team.