Topic: TiltViewer requires JavaScript and the latest Flash player. Get Flash

Hi - I have been using tiltviewerpro on one of my client's sites for a couple of years now and it has always woprked fine. 

However, the client reported the dreaded error message TiltViewer requires JavaScript and the latest Flash player. Get Flash here.
a few days ago.  I have checked and she is correct - none of the galleries are now working.

At first I thought it was Firefox 25 disabling javascript but it happens with all browsers.  I have checked in firefox that javascript is enabled and that the latest flash is installed.  I have made no changes to this area of the site for at least a year.  It is built in Wordpress but otherwise is nothing unusual - although I do update wordpress versions when they come along.  Not sure if this happened after the last update, maybe a month ago.

Could you help me trouble shoot this one please?

The link is http://www.natural-horsemanship-coin.com/ then choose any of the galleries under Galleries in the main menu

Thanks

Re: TiltViewer requires JavaScript and the latest Flash player. Get Flash

It looks like the files required for your galleries are no longer on your web server (or at least not in the correct locations).

For example, for your first gallery, the 'TiltViewer.swf' file should be located here: http://www.natural-horsemanship-coin.co … Viewer.swf
... and the 'swfobject.js' file should be located here: http://www.natural-horsemanship-coin.co … fobject.js

Going directly to either of these addresses directly in a browser results in an error 404 (file not found).
Make sure that your gallery files have been uploaded to the correct locations on your web server.

If the files appear to be in their correct locations and the problem still occurs, then check the permissions of the files to make sure that they are not too restrictive. (Default permissions of 755 for folders and 644 for files should work fine.)

Steven Speirs
SimpleViewer Support Team.

Re: TiltViewer requires JavaScript and the latest Flash player. Get Flash

Steven Speirs wrote:

It looks like the files required for your galleries are no longer on your web server (or at least not in the correct locations).

For example, for your first gallery, the 'TiltViewer.swf' file should be located here: http://www.natural-horsemanship-coin.co … Viewer.swf
... and the 'swfobject.js' file should be located here: http://www.natural-horsemanship-coin.co … fobject.js

Going directly to either of these addresses directly in a browser results in an error 404 (file not found).
Make sure that your gallery files have been uploaded to the correct locations on your web server.

If the files appear to be in their correct locations and the problem still occurs, then check the permissions of the files to make sure that they are not too restrictive. (Default permissions of 755 for folders and 644 for files should work fine.)

Thanks for replying so promptly.  Sorry for the delay in responding - been away on business and didn't receive the email telling me there was a new response.

As to your points:

1. I have never had either of these two files in the actual gallery folder. The swf file is in the root directory and the js file in the scripts folder. These appear to be correct for the code in the WordPress page:

<div id="instructions"><!--Begin Instructions text-->
<p>Wait for photos to load. Click photo to enlarge. Click circular arrow to flip image. Click image again to reduce.</p>
</div>
<!--End Instructions text-->
<div id="tiltviewer"><script type="text/javascript" src="scripts/swfobject.js"></script>
<div id="flashcontent">TiltViewer requires JavaScript and the latest Flash player. <a href="http://www.macromedia.com/go/getflashplayer/">Get Flash here.</a></div>
<script type="text/javascript">// <![CDATA[
var fo = new SWFObject("TiltViewer.swf", "viewer", "600", "450", "9.0.28", "#171515");

If I enter the url for those locations as per your observations above, I get positive results. In fact the default gallery opens just fine see: http://www.natural-horsemanship-coin.com/TiltViewer.swf and http://www.natural-horsemanship-coin.co … fobject.js

2. I have checked and both files have 0644 permissions.  As I say, the galleries have worked ok since first upload 2 years ago and I haven't made any changes to any of the files or locations (that I know of).

3. I am wondering if somehow a gremlin has crept into the code.  Here is the complete Wordpress code:

<div id="instructions"><!--Begin Instructions text-->
<p>Wait for photos to load. Click photo to enlarge. Click circular arrow to flip image. Click image again to reduce.</p>
</div>
<!--End Instructions text-->
<div id="tiltviewer"><script type="text/javascript" src="scripts/swfobject.js"></script>
<div id="flashcontent">TiltViewer requires JavaScript and the latest Flash player. <a href="http://www.macromedia.com/go/getflashplayer/">Get Flash here.</a></div>
<script type="text/javascript">// <![CDATA[
var fo = new SWFObject("TiltViewer.swf", "viewer", "600", "450", "9.0.28", "#171515");

// TILTVIEWER CONFIGURATION OPTIONS
// To use an option, uncomment it by removing the "//" at the start of the line
// For a description of config options, go to:
//http://www.airtightinteractive.com/projects/tiltviewer/config_options.html

//FLICKR GALLERY OPTIONS
// To use images from Flickr, uncomment this block
//fo.addVariable("useFlickr", "true");
//fo.addVariable("user_id", "48508968@N00");
//fo.addVariable("tags", "jump,smile");
//fo.addVariable("tag_mode", "all");
//fo.addVariable("showTakenByText", "true");

// XML GALLERY OPTIONS
// To use local images defined in an XML document, use this block
fo.addVariable("useFlickr", "false");
fo.addVariable("xmlURL", "demosandworkshopsgallery.xml");
fo.addVariable("maxJPGSize","640");

//GENERAL OPTIONS
fo.addVariable("useReloadButton", "false");
fo.addVariable("columns", "3"); fo.addVariable("rows", "3"); //fo.addVariable("bkgndInnerColor", "0xFFFFFF");
//fo.addVariable("bkgndOuterColor", "0xFFFFFF");
//fo.addVariable("frameColor", "0xAAAAAA");
//fo.addVariable("navButtonColor", "0x000000");
fo.addVariable("showFlipButton", "true");
fo.addVariable("showLinkButton", "false");
//fo.addVariable("linkLabel", "View image info");
//fo.addVariable("backColor", "0xDDDDDD");
fo.addVariable("langGoFull", "Go Fullscreen");
fo.addVariable("langExitFull", "Exit Fullscreen");
//fo.addVariable("langAbout", "About");
fo.addVariable('bkgndTransparent', 'true');  
fo.addVariable('showFullscreenOption', 'false');
// END TILTVIEWER CONFIGURATION OPTIONS

//PRO OPTIONS
fo.addVariable("zoomedInDistance", "1000");
fo.addVariable("zoomedOutDistance", "3400");
fo.addVariable("tiltAmountIn", "10");
fo.addVariable("tiltAmountOut", "10");
fo.addVariable("frameWidth", "10");
fo.addVariable("titleFontSize", "50");
fo.addParam("allowFullScreen", "true");
fo.addParam("wmode", "transparent");
fo.write("flashcontent");
// ]]></script></div>
<!--End of Tiltviewer -->
<p>&nbsp;</p>

I don't recognise the code <![CDATA[ ..... // ]]>  Should that be in there?

Thanks - Richard

Re: TiltViewer requires JavaScript and the latest Flash player. Get Flash

The relative paths to the 'TiltViewer.swf' and 'swfobject.js' files within your gallery's embedding code are incorrect.

Change:

<script type="text/javascript" src="scripts/swfobject.js"></script>

... to:

<script type="text/javascript" src="/scripts/swfobject.js"></script>

(The leading slash denotes your root directory.)

Also, change:

var fo = new SWFObject("TiltViewer.swf", "viewer", "600", "450", "9.0.28", "#171515");

... to:

var fo = new SWFObject("/TiltViewer.swf", "viewer", "600", "450", "9.0.28", "#171515");

If this does not work, you could use absolute paths such as:

<script type="text/javascript" src="http://www.natural-horsemanship-coin.com/scripts/swfobject.js"></script>

... and:

var fo = new SWFObject("http://www.natural-horsemanship-coin.com/TiltViewer.swf", "viewer", "600", "450", "9.0.28", "#171515");

Alternatively, you could leave your embedding code as it is and copy the 'TiltViewer.swf' file and the 'scripts' folder into your gallery folder.

Steven Speirs
SimpleViewer Support Team.

Re: TiltViewer requires JavaScript and the latest Flash player. Get Flash

Steven - thanks for the advice.

I have changed all references to absolute paths and now get the beginnings of a gallery display.  However, the gallery opens with a 3x3 display of blank photos and then they disappear one by one.  I have had this issue before years ago but can't remember how to fix it.  I have checked the reference to the xml file. It is absolute and it will open in a browser.  I  have also changed the urls in the xml file to absolute references.

The link in the WordPress page is  now:

fo.addVariable("xmlURL", "http://www.natural-horsemanship-coin.com/archivegallery.xml");

The website link to view is http://www.natural-horsemanship-coin.co … ve-photos/ (only changed one gallery)

FYI, the xml file looks like this:

<tiltviewergallery>
  <photos>

        <photo imageurl="http://www.natural-horsemanship-coin.com/galleries/archive//diwrist480.jpg" linkurl="http://www.google.com">
            <title>Diana and Boli - a broken wrist won't stop her!</title>            
        </photo>
        
        <photo imageurl="http://www.natural-horsemanship-coin.com/galleries/archive//benson480.jpg" linkurl="http://www.google.com">
            <title>Kerri and Benson</title>            
        </photo>
        <photo imageurl="http://www.natural-horsemanship-coin.com/galleries/archive//blackwhite480.jpg" linkurl="http://www.google.com">
            <title>Freddy, Dawn and Jeff with Sheewa, Principe and Negrita</title>            
        </photo>
        <photo imageurl="http://www.natural-horsemanship-coin.com/galleries/archive//boli480.jpg" linkurl="http://www.google.com">
            <title>Diana and Boli - true partners</title>            
        </photo>
        <photo imageurl="http://www.natural-horsemanship-coin.com/galleries/archive//canter480.jpg" linkurl="http://www.google.com">
            <title>Freddy and Principe - no bridle needed</title>            
        </photo>
        <photo imageurl="http://www.natural-horsemanship-coin.com/galleries/archive//danza480.jpg" linkurl="http://www.google.com">
            <title>Visitor, Janet Hakeney, with Danzarina</title>            
        </photo>
        
        <photo imageurl="http://www.natural-horsemanship-coin.com/galleries/archive//fincahiedra480.jpg" linkurl="http://www.google.com">
            <title>Finca heidra - just one of the stunning views</title>            
        </photo>
        
        <photo imageurl="http://www.natural-horsemanship-coin.com/galleries/archive//freya480.jpg" linkurl="http://www.google.com">
            <title>Christie and Freya learning one rein riding</title>            
        </photo>
        <photo imageurl="http://www.natural-horsemanship-coin.com/galleries/archive//principe480.jpg" linkurl="http://www.google.com">
            <title>Freddy and Principe in total harmony</title>            
        </photo>
        

</photos>
</tiltviewergallery>

which is in the same format as one of my other saites where the gallery works ok

Richard

Last edited by arjay (2013-11-23 11:33:26)

Re: TiltViewer requires JavaScript and the latest Flash player. Get Flash

The XML file for your gallery here: http://www.natural-horsemanship-coin.co … allery.xml
... specified by the following line of code:

fo.addVariable("xmlURL", "http://www.natural-horsemanship-coin.com/archivegallery.xml");

... does not contain the code you posted.
The imageURL entries in your XML file currently look like this:

imageurl="galleries/archive//diwrist480.jpg"

If you use relative paths for your imageURLs, then they should be relative to the page containing the embedding code.
In your gallery's case, they should look like this:

imageurl="../galleries/archive/diwrist480.jpg"

Alternatively, you could use:

imageurl="/galleries/archive/diwrist480.jpg"

or:

imageurl="http://www.natural-horsemanship-coin.com/galleries/archive/diwrist480.jpg"
Steven Speirs
SimpleViewer Support Team.

Re: TiltViewer requires JavaScript and the latest Flash player. Get Flash

Thanks Steven - using the full url in the xml files was the answer and all the galleries are now OK.

Still have no idea why they have worked just fine for 2 years with the original settings?.

Re: TiltViewer requires JavaScript and the latest Flash player. Get Flash

If everything was working OK but suddenly stopped working without you doing anything yourself, then something must have changed on your web server for this to happen.
Perhaps your web server experienced a problem and had to reinstate your site from an incomplete backup (or from a time when everything was not working correctly). You could try asking your web host to see if anything had changed on your site recently.

Steven Speirs
SimpleViewer Support Team.