Topic: Publish gallery to my website is not working [SOLVED]

svBuilder:

Saved the gallery to a folder
Uploaded the folder to my server
Index Page Name: index.html or svindex.html  (the page I want to show the gallery is http://rosaportraitstudio.com/index.html)
Copy and Pasted the Embed Code to the page by Insert/Code Elements/HTML

Save and published my site (Yahoo Sitebuilder)

The gallery is just not showing. Anything wrong?

Appreciate for your help.
Rosa

Re: Publish gallery to my website is not working [SOLVED]

According to your gallery's embedding code, your 'simpleviewer'js' file should be located here on your web server:
http://rosaportraitstudio.com/svcore/js/simpleviewer.js
... but it is not there.

If you are following the embedding instructions here, then you should copy the contents of your gallery folder (not the folder itself) to the same directory as the HTML page into which you are embedding the gallery. In your case, this is the root directory of your web space, alongside your 'index.html' file. (Do not upload the gallery's own 'index.html' file, though. It is not required when embedding the gallery in an existing page and it will overwrite your own 'index.html' file.)

If you want to keep your gallery in its own folder, then you can upload the complete gallery folder to anywhere on your web server and use the baseURL method of embedding as documented here.

However, at the moment, all you need to do to have your gallery displayed on your web page is to upload the content of your gallery folder to your root directory.

Steven Speirs
SimpleViewer Support Team.

Re: Publish gallery to my website is not working [SOLVED]

Thank you very much Steven, it works!

More questions, see http://rosaportraitstudio.com

1) When click on the portrait image at the bottom such as #4, it does not display full size.  What I can do to let all images display as original portion?
2) I chose Flash but it's not playing automatically?
3) When open it on Andrio phone, the top big size image does not show, only thumb?(It does display as original portion)  (I use Compact gallery style)

Thank you in advance!
Rosa

Last edited by rosah (2014-03-15 03:48:18)

Re: Publish gallery to my website is not working [SOLVED]

1) When click on the portrait image at the bottom such as #4, it does not display full size.  What I can do to let all images display as original portion?

(I use Compact gallery style)

Please see this FAQ:
Why are my images cropped when using the Compact Gallery Style?

2) I chose Flash but it's not playing automatically?

If you want your SimpleViewer gallery to AutoPlay automatically when the gallery loads, you will need to set autoPlayOnLoad="TRUE".
For reference,a complete list of AutoPlay options can be found here.
Please note that these options are available to SimpleViewer-Pro only (and not SimpleViewer-Standard, the free version).

3) When open it on Andrio phone, the top big size image does not show, only thumb?(It does display as original portion)

Please see these FAQs:
When I view my gallery I see a grid of thumbnails, not the layout I specified. Why?
The mobile player layout does not match the Flash player layout. Why not?

Steven Speirs
SimpleViewer Support Team.

Re: Publish gallery to my website is not working [SOLVED]

Thank you again Steven!

The gallery on my home page is working well (http://rosaportraitstudio.com/index.html)

More help please(could not figure out with the existing instructions). Multiple Galleries on Separate HTML Pages ( http://rosaportraitstudio.com/baby.html)

I created the gallery as another folder. How to upload the files to the page? I am afraid to cover the files of 1st gallery (images, svcore, thumbs, gallery) since they are under the root of my website and same file name. If I change the file name, it does not pick up and the gallery shows the images of the 1st gallery. I upload the whole folder too, the gallery does not show.

Thanks,
Rosa

Re: Publish gallery to my website is not working [SOLVED]

I am afraid to cover the files of 1st gallery (images, svcore, thumbs, gallery) since they are under the root of my website and same file name.

Use the baseURL method of embedding documented here.
This allows you to keep all the gallery files inside the gallery folder and you would upload the entire gallery folder (not just the contents) to your web server. As long as each gallery folder has a unique name, then there will be no duplicate name conflicts on your web server.
It does not matter where on your web server you upload your gallery folder to as long as the two paths in the gallery's embedding code (the path to the 'simpleviewer.js' file and the baseURL itself) are correct.

Steven Speirs
SimpleViewer Support Team.

Re: Publish gallery to my website is not working [SOLVED]

It worked again, thanks Steven!

Small problem:

The tile shows half? (tried resize but not working) (http://rosaportraitstudio.com/baby.html)
The background shows darkgrey instead of black as selected with baseURL?

Thanks,
Rosa

Re: Publish gallery to my website is not working [SOLVED]

Big problem:

The gallery created by baseURL does not run on Andriod/Iphone?

Would you please advise how to make Multiple Galleries on Separate HTML Pages by the 1st method - copy the files to web root not the whole folder?

Thanks again,
Rosa

Re: Publish gallery to my website is not working [SOLVED]

The tile shows half?

Unfortunately, this looks like a bug in SimpleViewer-Standard, whereby if you set thumbPosition="BOTTOM" and choose not to display any Button Bar buttons, then the top area is not given sufficient height to display the title.
I have logged a bug report with the developers and it will hopefully be fixed in the next version.
In the meantime, if you used SimpleViewer-Pro, you could rectify this by setting floatTitle="FALSE" and then set a titleHeight. However, these options are available to SimpleViewer-Pro only (and not SimpleViewer-Standard).
Possible workarounds for SimpleViewer-Standard would be to display a Button Bar button or to change the layout of your gallery.

The background shows darkgrey instead of black as selected with baseURL?

This is due to the backgroundColor Embed Code Parameter set in your gallery's embedding code (on your http://rosaportraitstudio.com/baby.html page).
Change:

simpleviewer.load("sv-container", "100%", "100%", "222222", true, flashvars);

... to:

simpleviewer.load("sv-container", "100%", "100%", "000000", true, flashvars);

The gallery created by baseURL does not run on Andriod/Iphone?

The Mobile Player (HTML) version of the gallery requires that all the gallery files are on the same domain or subdomain as the web page containing the gallery's JavaScript embedding code. This is due to the same-origin policy.

The paths within your gallery's embedding code (the path to the 'simpleviewer.js' file and the baseURL) are currently absolute and use the www.rosaportraitstudio.com subdomain.
If you go to your web site via www.rosaportraitstudio.com (i.e. using the 'www' subdomain), then you should see the gallery displayed on your mobile device.

A simple solution would be to use relative paths (rather than absolute paths) in your gallery's embedding code and the gallery will then be displayed on both rosaportraitstudio.com and www.rosaportraitstudio.com.
Try code such as the following:

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="/SVbaby/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars = {};
flashvars.baseURL = "/SVbaby/";
simpleviewer.ready(function () {
simpleviewer.load("sv-container", "100%", "100%", "000000", true, flashvars);
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->

The leading slash in the code above denotes your root directory.

Would you please advise how to make Multiple Galleries on Separate HTML Pages by the 1st method - copy the files to web root not the whole folder?

By using relative rather than absolute paths in your embedding code, you should be able to use the baseURL method without problem. If you choose to not use the baseURL method, then all the files for all your galleries would end up in the same directory and things might begin to get a little disorganized. You would also need to give each gallery's XML file a unique name (to avoid duplicate file name conflicts) and point each gallery towards its own XML file using the galleryURL config option. (However, the galleryURL would also need to be relative rather than absolute.)

Steven Speirs
SimpleViewer Support Team.

Re: Publish gallery to my website is not working [SOLVED]

Thank you very much Steven, all problems solved! Will go with the Pro later:)