Topic: Another Flickr issue [SOLVED]

Hi All

I have multiple Simpleviewer pro galleries all on the same site. Each of the galleries are pointed at a different flickr gallery.

I have followed the resolution steps on this forum i.e. I upgraded the SVBuilder and if I now load a gallery I can see it locally.

On my site the update gallery still does not appear. I have never had to upload anything on my site other than the xml and swf files. Do I now need the svcore folder?

I have been using simpleviewer for a long time and so my html code might be quite old but I just need to know if there is a quick way to recover this situation without recreating loads of new galleries and editing lots of html pages.

So I have multiple galleries all on the same site. In the root of the site I have files called gallery1.xml, gallery2.xml and gallery3.xml together with simpleviewer1.swf, simpleviewer2.swf and simpleviewer3.swf.

The html code referenced each of these galleries with the following code

<script type="text/javascript">
var flashvars = {};
flashvars.galleryURL = "gallery1.xml";
var params = {};
params.bgcolor = "F0F0F0";
params.allowfullscreen = true;
params.allowscriptaccess = "always";
swfobject.embedSWF("simpleviewer1.swf", "flashContent", "600", "550", "9.0.124", false, flashvars, params);
</script>

The gallery is then called in a div <div id="flashContent">

This does not seem to work anymore and I would seem to have to create everything from scratch?

Please tell me this is not the case? sad

Re: Another Flickr issue [SOLVED]

Just further to the above the embed code does appear to be different in simpleviewer pro v2 however I have never had to change this with previous updates I was always just able to reference the xml and swf files.

Do I now need to change all of my galleries to call the jscript and reference the contents of the svcore folder?

This will be a massive undertaking just because Flickr changed there API?

Re: Another Flickr issue [SOLVED]

All you need to do to get your Flickr galleries working again is to replace the SWF files in your galleries with the new SWF file from the SimpleViewer-Pro v2.3.2 zip package. There is no need to modify any of your HTML or XML files.

Extract the SimpleViewer-Pro v2.3.2 zip package and use the 'simpleviewer.swf' file from the 'simpleviewer_pro_2.3.2/web/svcore/swf/' folder to replace the existing SWF files on your web server. (You will need to rename it to match the names you currently use in your embedding code.)

If you like, all your galleries could share a single instance of the 'simpleviewer.swf' file. It remains the same for each and every gallery. You could upload the file to your web server once and then point all your galleries towards it.
In doing so, the next time SimpleViewer is updated, you would need to just swap one file on your web server to update all your galleries at once.

Please note that the 'svcore' folder would be required (with an change of embedding code in your HTML files) for your galleries to support Universal Playback.

Steven Speirs
SimpleViewer Support Team.

Re: Another Flickr issue [SOLVED]

Brilliant Steven

Thanks for your help that seems to have worked
big_smile