Topic: Embed - Nothing displayed on Page

I'm running Sv BuilderPro 2.1.2 (cant find old email to upgrade unfortunately)
Having had success with the iframe i noticed its wasnt viewing properly on my Samsung Note phone. I have been l

I think that i read on 1 of your pages an embed system was the way to go?
Anyway heres my code Im pasting into my WP page but nothing is appearing. Can you help please. Many thanks Martin

<!--START SIMPLEVIEWER EMBED.-->
<script src="http://www.martincrombie.co.uk/weddings/simpleviewer/gallery3FS/svcore/js/simpleviewer.js" type="text/javascript"></script><script type="text/javascript">// <![CDATA[
var flashvars={};     flashvars.baseURL="http://www.martincrombie.co.uk/weddings/simpleviewer/gallery3FS/";     simpleviewer.ready(function () {         simpleviewer.load("sv-container", "850", "600", "FFFFFF", true, flashvars);     });
// ]]></script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->

Re: Embed - Nothing displayed on Page

This is the page it should appear on btw i have cut ands paste the previous html into.
http://www.martincrombie.co.uk/weddings … iewer.html

This link works fine it views perfectly as a standalone page http://www.martincrombie.co.uk/weddings … allery3FS/

Hope this makes sense.

Re: Embed - Nothing displayed on Page

I'm running Sv BuilderPro 2.1.2

First of all, it would probably be wise to upgrade to the current version of SimpleViewer (v2.3.2).
There have been many bugfixes since v2.1.2. Please see the Version History for details.

(cant find old email to upgrade unfortunately)

Please fill in this Upgrade Request Form to the best of your ability to request a new download link (so that you can download SimpleViewer v2.3.2).

I think your problem is related to the version of SimpleViewer that you use and the embedding code you use.
The syntax for the embedding code was changed some time after v2.1.2.

Solutions would be to either:
(1) Upgrade your gallery to SimpleViewer v2.3.2 and leave your (new style) embedding code exactly as it is.
... or:
(2) Change your embedding code to the old style as follows:

<!--START SIMPLEVIEWER EMBED.-->
<script src="http://www.martincrombie.co.uk/weddings/simpleviewer/gallery3FS/svcore/js/simpleviewer.js" type="text/javascript"></script>
<script type="text/javascript">
    var flashvars={};
    flashvars.baseURL="http://www.martincrombie.co.uk/weddings/simpleviewer/gallery3FS/";
    jQuery(document).ready(function () {
        SV.simpleviewer.load("sv-container", "850", "600", "FFFFFF", true, flashvars);
    });
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->

The later versions of SimpleViewer are backwards compatible and will work fine with both the old style and new style embedding code but SimpleViewer v2.1.2 works only with the old style embedding code.

This should hopefully solve your problem.

Steven Speirs
SimpleViewer Support Team.

Re: Embed - Nothing displayed on Page

Thanks Stephen.
Yes just changed it to html version 'false' looks ok now.

One last change please the spacing at the top of the gallery needs reducing is this a caption height issue perhaps? http://www.martincrombie.co.uk/weddings … iewer.html

If so, can I alter this directly in the simpleviewer.css without each time going into SVBuilder?

Many thanks,

Re: Embed - Nothing displayed on Page

Yes just changed it to html version 'false' looks ok now.

Just for clarification, you do not need to use the Mobile Player. You can still use the Flash Player if you wish. The only change that was needed to have your gallery display was to change simpleviewer.ready(function () to jQuery(document).ready(function () and simpleviewer.load to SV.simpleviewer.load.

the spacing at the top of the gallery needs reducing

Please see the Layout Troubleshooting section of the SimpleViewer-Pro Layout Guide which deals with the query "I have extra spacing in my gallery. How do I get rid of it?" and has several suggestions which may help.

As your gallery currently use the Mobile Player, the main images always display right up to the top and bottom edges of the gallery's container so when you view a main image in your gallery, any space above the main image is coming from your web page rather than from within the gallery itself. Perhaps you can take a look at your WordPress theme's CSS and reduce any margin or padding that is used around any content.

Also, I notice that there are <p> tags throughout your gallery's embedding code (which can be seen in the source of your web page and which might be introducing some unwanted space). These tags may be inserted by WordPress's wpautop function. Perhaps your current theme is using this functionality.
Try temporarily reverting to a default WordPress theme to see if this makes a difference.
Also, try installing the wpautop control plugin and use it to disable wpautop in your pages and posts containing SimpleViewer galleries.

Steven Speirs
SimpleViewer Support Team.

Re: Embed - Nothing displayed on Page

Hi Steven,

Yes I see the <P> tags </>  just before the simpleviewer javascript.
I was provided some custom code to remove it now fixed on my homepage. Not sure how they fixed it but big_smile 
http://www.martincrombie.co.uk/weddings/

body.page-id-411 .article-content p:nth-of-type(1) {display: none;}

Cheers Martin

btw, thanks also for the link to the upgrade.

Re: Embed - Nothing displayed on Page

I'm glad everything is now working as expected.
Thank you for posting back to let me know.

Steven Speirs
SimpleViewer Support Team.