Topic: Gallery XML Not Found

Hi.
Installed WP-SimpleViewer yesterday and upgraded to pro. Created gallery in svBuilder-Pro and get this message:

screens;

http://s.gullipics.com/image/7/z/0/jonltrz-kgs3r3-o826/ScreenShot20141012at090421.png
http://s.gullipics.com/image/5/u/9/jonltrz-kgs3p7-mffl/ScreenShot20141012at085213.png

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="http://www.photo-passion.co.uk/public_html/santino/SimpleViewer/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars={};
flashvars.baseURL="http://www.photo-passion.co.uk/public_html/santino/SimpleViewer/";
simpleviewer.ready(function () {
simpleviewer.load("sv-container", "100%", "100%", “000000”, true, flashvars);
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->

Can someone help me with this?

Many thanks.

Re: Gallery XML Not Found

The 'public_html' directory name should not appear in URLs (unless you have specifically created a new folder named 'public_html' inside your original 'public_html' directory.
Also, hard-coding the 'www' subdomain in the paths within your gallery's embedding code means that the gallery may not display on your main domain (without the 'www') due to the same-origin policy.
Use paths starting with a leading slash to denote your root directory and remove 'public_html' from the path names.
Try the following:

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="/santino/SimpleViewer/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
    var flashvars={};
    flashvars.baseURL="/santino/SimpleViewer/";
    simpleviewer.ready(function () {
        simpleviewer.load("sv-container", "100%", "100%", “000000”, true, flashvars);
    });
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->

The screenshot you posted does not seemt o correspond with what I see on your web server.
It looks like you should have a complete gallery folder here http://photo-passion.co.uk/santino/SimpleViewer/ (or possibly here http://photo-passion.co.uk/public_html/ … pleViewer/) but neither seems to exist.
Please check the files on your web server and if you continue to experience difficulties, please post the URL to the web page into which you are trying to embed the gallery so that I can take a look and help further.

Steven Speirs
SimpleViewer Support Team.

Re: Gallery XML Not Found

Thank you for replay just paste code and http://photo-passion.co.uk/santino/simple/

http://s.gullipics.com/image/e/4/g/jonltrz-kgs98y-klhx/ScreenShot20141012at112710.png

this is the url http://photo-passion.co.uk/santino/

but works here http://photo-passion.co.uk/santino/SimpleViewer/

I'm confused now.

Last edited by marsuss (2014-10-12 10:29:06)

Re: Gallery XML Not Found

Your gallery here http://photo-passion.co.uk/santino/SimpleViewer/ works fine now (but it didn't when I tried it earlier).
Now that it works, the embedding code I posted in my last post should work fine. If your gallery still does not display when using this embedding code, then try clearing your browser's cache before reloading your web page to ensure that your browser is fetching and using the most recent files from your web server.

One thing I should have mentioned earlier:

Installed WP-SimpleViewer yesterday

If you intend to manually embed your galleries into your WordPress posts (by uploading complete gallery folders and inserting embedding code into your WordPress posts), then there is no need to have installed WP-SimpleViewer. WP-SimpleViewer allows you to create galleries within the WordPress Dashboard and the plugin automatically handles the embedding code for you. Instructions for use can be found here.

Steven Speirs
SimpleViewer Support Team.

Re: Gallery XML Not Found

Steven Speirs wrote:

If your gallery still does not display when using this embedding code, then try clearing your browser's cache before reloading your web page to ensure that your browser is fetching and using the most recent files from your web server.

Did this, but no luck.

Steven Speirs wrote:

If you intend to manually embed your galleries into your WordPress posts (by uploading complete gallery folders and inserting embedding code into your WordPress posts), then there is no need to have installed WP-SimpleViewer.

I prefer svBouilder-pro, so can i just delete WP-SimpleViewer plugin from wordpress?

Last edited by marsuss (2014-10-12 20:10:53)

Re: Gallery XML Not Found

Did this, but no luck.

I have just noticed that you do not use standard double-quotes to enclose the background color Embed Code Parameter in your gallery's embedding code. This may be causing a problem.
Try the following:

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="/santino/SimpleViewer/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
    var flashvars={};
    flashvars.baseURL="/santino/SimpleViewer/";
    simpleviewer.ready(function () {
        simpleviewer.load("sv-container", "100%", "100%", "000000", true, flashvars);
    });
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->

If your gallery still does not display, then try using fixed pixel dimensions instead of percentages to see if this makes a difference. (Your web page uses animation on loading and the gallery's parent container may have no dimensions at the time the gallery is loaded so SimpleViewer may currently calculate the gallery's dimensions to be 100% x 0px = 0px.)

I prefer svBouilder-pro, so can i just delete WP-SimpleViewer plugin from wordpress?

Yes. If you choose to manually embed your SimpleViewer galleries in your WordPress posts, then there is no need to have WP-SimpleViewer installed.

Steven Speirs
SimpleViewer Support Team.