Topic: Multiple galleries not working

Hello,

I've got multiple web pages that each point to a different Simpleview gallery. I followed the FAQ instructions create whole implementations of simpleviewere folder for each gallery.

I try to use FlashVars to point to the correct ImageData.xml file. (see code below)

In the .xml file, I set image and thumbs pointers to the file locations.

Sooo, for one implementation of this, it all works. When I load in the other one, I get placeholders for the thumbs and the loading image graphic comes up...but nothing loads...it just sits there.

I've tied to troublshoot in many different ways, without success.

Any thoughts?

Thanks.


<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0" width="640px" height="800px" id="viewer" align="middle">
<param name="allowScriptAccess" value="sameDomain" />
<param name="movie" value="simpleviewer/april2006/viewer.swf" />
<param name="quality" value="best" />
<param name="bgcolor" value="#222222" />
<param name="FlashVars" value="xmlDataPath=simpleviewer/april2006/imageData.xml" />
<embed src="simpleviewer/april2006/viewer.swf" quality="best" bgcolor="#222222" width="640px" height="800px" name="viewer" align="middle" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" FlashVars="xmlDataPath=simpleviewer/april2006/imageData.xml" pluginspage="http://www.macromedia.com/go/getflashplayer" />
</object>

Re: Multiple galleries not working

To have multiple SimpleViewer galleries, you do not neeed to set any paths to XML or SWFs. Just make a copy of the SimpleViewer folder (that comes with the download) for each gallery. Put your images and XML in each folder. That's it!

Felix Turner
SimpleViewer Support Team.

Re: Multiple galleries not working

Felix,

I am also looking at doing a site with multiple galleries but even a site with one gallery produces the same question from me. How do I put links in a gallery? Once my visitor is done viewing the photo gallery I want to provide them with links to other pages on my website. Why isn't this built in to the viewer? Is it built in on the pay version were I can type in my links and have them appear in the gallery?

Jim

Re: Multiple galleries not working

15: How do I create multiple galleries?
To create multiple galleries of images, make a copy of the whole SimpleViewer folder for each gallery. Create your individual galleries as normal. You can now create a menu page that links to the index.html page in each sub-folder. Alternatively, you can use SimpleViewerAdmin to handle multiple galleries.

[url]http://www.photographybykevin.net[/url]

Simple Viewer FAQ By Kevin
[url]http://knguyentu.com/wordpress/photography-by-kevin/simpleviewer-flash-photo-gallery/[/url]

Re: Multiple galleries not working

smilepak,

I appreciate you showing me code for a page that has a list of links but I have my page ready to go except for the links (http://www.rhumbuzzz.com/pictures) and I need a relatively easy solution to adding the links. The code you offer would have me start all over. Is there an easier way to just add a links menu or I'd even settle for a single text link that allows the visitor to return to the main site

I was able to add a text link but it appeared at the top of the page with a different color background than I had established on the page. On my page I'd like to put a text link just above or below the main photo window. Is that impossible or would I have to rewrite the viewer.swf?

If I can't do it that way and a menu off the the left becomes necessary, is there any other way rather than starting all over with the code you've provided?

Jim

Re: Multiple galleries not working

Smile,

For the rhumbuzzz site I'm only interested in one gallery page. I may be working with multiple galeries for my own site but right now I just want a solution to the single gallery link issue. Thanks.

Jim

Re: Multiple galleries not working

Smile,

For the rhumbuzzz site I'm only interested in one gallery page. I may be working with multiple galeries for my own site but right now I just want a solution to the single gallery link issue. Thanks.

Jim

Regardless if you are doing one gallery vs multiple galleries. You will have to embed the simpleviewer tag around a table of some sort.

In another word, embed it inside your normal HTML design. There is absolutely no way around it.

Since you are not doing PHP, ASP, or one of the dynamic method of webdesign, you can't have just an index page with only the simpleviewer tag and expect it to give you a link to other things on yoursite.

[url]http://www.photographybykevin.net[/url]

Simple Viewer FAQ By Kevin
[url]http://knguyentu.com/wordpress/photography-by-kevin/simpleviewer-flash-photo-gallery/[/url]

Re: Multiple galleries not working

"Since you are not doing PHP, ASP, or one of the dynamic method of webdesign, you can't have just an index page with only the simpleviewer tag and expect it to give you a link to other things on yoursite."

I understand your point. I just don't know how to do it.

Jim

Re: Multiple galleries not working

Jim,

I've added an example page showing how to embed SimpleViewer inside a HTML page, allowing room for a header and footer, where you can place your back link. Please check the FAQ, Q9: http://www.airtightinteractive.com/simp … r/faq.html

Felix Turner
SimpleViewer Support Team.

Re: Multiple galleries not working

I've added an example showing how to add a HTML menu to link to multiple SimpleViewer galleries : http://www.airtightinteractive.com/simp … /gallery1/

Felix Turner
SimpleViewer Support Team.

Re: Multiple galleries not working

I've added an example showing how to add a HTML menu to link to multiple SimpleViewer galleries : http://www.airtightinteractive.com/simp … /gallery1/

Felix,

If you are using Porta to create all the files and uploading them to the server via FTP, would the method to "embed" the simpleviewer in HTML code be the same?