Topic: SV 1.8 suddenly not working: previous galleries still fine

I'm using SV 1.8 and have been using it for the past year, so I'm pretty familiar with the whole process. I have a template folder, with all the SV files in it: I throw the new images into the images folder, update the buildgallery.php and html file with the proper gallery title, and change the name of the html file. Then I just upload the lot to my site's "photos" folder. I currently have some 30 galleries on my site, including my portfolio, which uses SV.

Anyway, just 2 days ago, when uploading a new gallery and running buildgallery.php, everything seemed to be going fine. However, when I go to the gallery page, all I see are the thumbnail boxes and the "loading image" message in the main area. Checking the image and thumbs folders shows that the thumbnails have been created, and the xml file has been properly updates. Incidentally, the number of blank thumbnail squares on the page reflects the proper number of images.
http://www.agonyagogo.com/photos/541-ea … b2007.html

Manually typing in the address of the images or thumbs displays them just fine.

The images are NOT progressive jpgs, they are baseline. There are no caps involved in the folders or file names. I've checked this on IE, Netscape, and Firefox.

It's just seems that I can't properly run new scripts on my server. I've even copied an existing, working gallery folder- renamed it and uploaded it. Same result- thumbnails created, xml update, gallery doesn't show any images.

I've contacted my site's server host, but I haven't heard back yet. Thought I'd ask all you folks, since my host might not be so familiar with the SV script.

I don't know if you'll need it, but my photogallery site is: http://www.agonyagogo.com/photos/FFIIImain.html

Just a bunch of personal photos, so don't expect to see photographic beauty or something.

Anyway, hope someone can help out. Thanks, in advance.


Kurt

Re: SV 1.8 suddenly not working: previous galleries still fine

I'm currently trying all sorts of things, to no avail. One thing I noticed, though- if I follow the SimpleViewer - Automatic Web Server Instructions , it says: "Set file permissions/attributes on the build script, gallery.xml and thumbs folder to 'read/write/execute' for all levels (777). You can do this with your FTP program, check the documentation"


Well, I have no file called gallery.xml- I assume they mean imageData.xml. If I set all these to 777 and then run buildgallery.php through my browser, I get an error from my host server: "An internal server error was encountered while trying to access the document which you requested. The most likely cause of this error is a misprogrammed Web script."

I never had to set this before, but I'm trying everything. If I set the permissions to the default: 644(read, write - read  - read), the script seems to run, but then I have the blank thumbnail problem stated above.


Anyone? Anyone? Bueller?[/i]

Re: SV 1.8 suddenly not working: previous galleries still fine

This got solved! Here is what my server admin wrote:
I see the Simple Viewer script in photos/test3 - is that the one?  All of
the images in the images/ and thumbs/ folders were generated, but it looks
like the ones in the thumbs/ folder were created with mode 600 - which
means they can't be read, except by a PHP script.  If you uploaded them
manually, just make sure to change the mode to 644 after uploading; but it
looks to me like Simple Viewer generates the thumbs.

I'm not exactly sure why files weren't being created with the right mode;
it may be related to a PHP security update I installed this week.  In any
case, I added this line near the top of buildgallery.php:

umask(022);

That causes any new file the script creates to be created with the right
mode.  I reran the script, and it seems to work. smile


Well, I added umask(022); to my buildgallery.php file, and it worked like a charm.

Kurt

Re: SV 1.8 suddenly not working: previous galleries still fine

Thanks for the solution.

Felix Turner
SimpleViewer Support Team.