Topic: Dynamix xml generation with Mambo

Hi all,

I am having a problem when trying to make SimpleViewer work when I dynamically generate the XML file.

Here is what I have:

<script type="text/javascript">
   var fo = new SWFObject&#40;"components/com_gallery/viewer.swf", "viewer", "100%", "100%", "7", "#181818"&#41;;    
   fo.addVariable&#40;"preloaderColor", "0xffffff"&#41;;
   fo.addVariable&#40;"xmlDataPath", "index.php?option=com_gallery&task=makealb"&#41;;
   fo.write&#40;"flashcontent"&#41;;
</script>

The xmlDataPath is in fact a call to a page that returns xml content using php header function:

<?php
$xmlCode = makeXML&#40;&#41;;
header&#40;'Content-Type&#58; application/xml; charset=UTF-8'&#41;;
header&#40;'Content-Disposition&#58; inline; filename="alb.xml"'&#41;;
header&#40;"Content-Length&#58; ".strlen&#40;$xmlCode &#41;&#41;;
header&#40;'Expires&#58; 0'&#41;;
header&#40;'Pragma&#58; cache'&#41;;
header&#40;'Cache-Control&#58; private'&#41;;
echo $xmlCode ;
die&#40;&#41;;
?>

The application just displays crosses. Not even the captions of the images. this makes me think that the xml data sent is not valid, but I have checked the data sent and it is a valid gallery xml file.

I would like to know if someone spoted something wrong with the php code.

I am using Mambo CMS. Are there any know issues that would prevent me doing this?



Thanks a lot,

Guillaume

Re: Dynamix xml generation with Mambo

Sounds like an issue with your generated XML. Do you have a sample XML url I can look at?

Felix Turner
SimpleViewer Support Team.

Re: Dynamix xml generation with Mambo

Your PHP script does return the filename and path of the XML file or just the code ? I think it should be the first
Roberto