Topic: Hyperlink Hot-Spot Problem in SWF Image Files

I am not only using Auto Viewer Pro to display photo images, but also text based images I have created and these images also contain URL links I have added to them within the Flash SWF files. As a result, I am now having a problem with most of the "Get URL" links that I place within the SWF files to work properly when running in Auto Viewer Pro.

The issue is that the Viewer.SWF file makes almost the entire display area of the picture a button hit spot for advancing the "Next" and "Back" buttons which are used to advance the image forward and backward in Auto Viewer Pro. Why the hit area does not only fall within the area of the "Next" and "Back" buttons themselves is also a mystery to me.

Because of this though, the bigger problem is that most of my Get URL links in the SWF files are not active when you put your mouse over them. Instead, the mouse-over action activates the "Next" and "Back" buttons instead.

I did find though as long as the Get URL links are placed towards the bottom of the picture area that they work OK, but often I want to place them at the top or middle of the image and then it is just impossible.

I have gone though the Options file carefully and tried various settings in the //controls options section of Auto Viewer Pro to try and reduce the area of the button hit spots, but all is to no avail.

If you go to the following link and advance to the second image you will see a whole bunch of Get URL links that are at the top of the image (they are the text areas in orange color) and none of them are active at all. If you put your mouse over them to try and click on any of them, all you get is the "Next" and "Back" buttons appearing as I mentioned: … llery.html

Any ideas on how to reduce the hit area for the "Next" and "Back" buttons so that the Get URL links in the SWF file become visible and active to the user would be much much appreciated.

Re: Hyperlink Hot-Spot Problem in SWF Image Files

The next and back button hit areas fill the left and right 1/3s of the image. To make the button hit area be only the size of the button graphic, do the following:

1) In, set hideControlsOnRollOut to false

2) In change these 4 lines

mHit_mc.onPress = Delegate.create(this,onPress);
mHit_mc.onRelease = Delegate.create(this,onRelease);
mHit_mc.onReleaseOutside = Delegate.create(this,onReleaseOutside);
mHit_mc.useHandCursor = false;    

to this:

mBtn_mc.onPress = Delegate.create(this,onPress);
mBtn_mc.onRelease = Delegate.create(this,onRelease);
mBtn_mc.onReleaseOutside = Delegate.create(this,onReleaseOutside);
mBtn_mc.useHandCursor = false;    
Felix Turner
SimpleViewer Support Team.

Re: Hyperlink Hot-Spot Problem in SWF Image Files

Thank you, that did the trick. The remaning hit spot on the button is a bit quirky though. If you click anywhere within the arrow itself there is a dead hit-spot there. You can go back to the link I provided above and see for yourself.

Re: Hyperlink Hot-Spot Problem in SWF Image Files

I'm using Autoviewer Pro to display images with getURL links (Flash symbols with getURL behavior) saved as .swf files. I can see my swf files in Autoviewer but my 'hotspots' are not active (though they are when I play the file in Flash 8). I followed the directions in this thread to reduce the area taken up by the nav arrows thinking this would resolve the issue, but I'm still getting the same result. Any ideas what could be happening?

Re: Hyperlink Hot-Spot Problem in SWF Image Files

so how is this being done? do i have to have pro?

i want to add links to each photo that link to another page, and open in the same window.

help please?

Re: Hyperlink Hot-Spot Problem in SWF Image Files

same problem here.. tho i have the buttons fixed now.. but now my swf file will not work when i put it in autoviewer pro.

it works on its own tho but not when i import it. any idea why this is?

because of this i was trying to use caption links instead.. but for some reason it only works on the first image.. eventho i copied and pasted the code onto the other images its not working.

PLEASE help felix!!


Re: Hyperlink Hot-Spot Problem in SWF Image Files

This issue has been resolved in AutoViewer 1.4. You can use caption links for image links.

Felix Turner
SimpleViewer Support Team.

Re: Hyperlink Hot-Spot Problem in SWF Image Files

Hi All,

Congratulations on such a sleek looking and useful app Felix. But I am having a bit of trouble with the AutoViewer Pro that I purchased.

I would like to use the same function as marcbkk in his original post, ie, allow links on the swf to be clickable. I have even looked at the copy of auto viewer that he has running on his site, and used it to test with my own images.

Everything is working well, except the autoviewer from marcbkk's site has the arrors for next and forward set in from the edge of the screen, and it is not utilise the full width and height of the browser.

I was wondering if I could enable the hit box's of my own embedded swf flash files, without changing any of the existing layout. As this is my first post, I dont think I am able to post a link to any test's that I have online.

Re: Hyperlink Hot-Spot Problem in SWF Image Files


to enable loaded swf button clicks in AutoViewer v1.4, comment out of the following lines in

lines 190+191

//mcLoader.onRelease = null;
//mcLoader.useHandCursor = false;

and lines 198+199
//mcLoader.onRelease = Delegate.create(this,onRelease);
//mcLoader.useHandCursor = true;

Then republish the SWF (check step 2.5 here: … #customize )[/code]

Felix Turner
SimpleViewer Support Team.