Topic: Transparent background

hey hi! I know there has been some forum posts like mine, i read them and it still don't work...

here is my simpleviewer http://www.amelierobert.com/en/port.html (there is music so turn down your speakers  roll)

how can I make the background transparent? I have this in my index.html file..

    <script type="text/javascript">

        var fo = new SWFObject&#40;"viewer.swf", "viewer", "100%", "100%", "8", "#ffffff"&#41;;    
        &#91;i&#93;***->&#91;/i&#93;fo.addParam&#40;"wmode", "transparent"&#41; 
        fo.addVariable&#40;"preloaderColor", "0x8faf06"&#41;;

thanks!

Re: Transparent background

forget it I have it done  big_smile

Re: Transparent background

How How How did you do it?

This is something that I am probably going to have to do.

Cheers,

Dave.

Re: Transparent background

Hah, nevermind, here is the source code form your website that I think does the trick.

smile
smile

<script type="text/javascript">          
var fo = new SWFObject&#40;"viewer.swf", "viewer", 
"100%", "100%", "8", "#ffffff"&#41;;        
fo.addParam&#40;"wmode", "transparent"&#41;
fo.write&#40;"flashcontent"&#41;;          
</script>

Re: Transparent background

This dosen't work  sad

Can I see the complete code?

Re: Transparent background

Worked fine for me.

I have simpleviewer galleries that can be seen here:

http://www.airbrushworld.com.au/  and
http://www.badattituderacing.com.au/galleries.php

just head to the galleries.

Have a look at the code.

I loooooove simpleviewer.

DAVE

smile

Re: Transparent background

Very nice, I love it too  8)

Sorry, but tha code dos'nt work on my site.  sad 

This is the Code:

  <script type="text/javascript">
     var fo = new SWFObjec&#40;"viewer.swf", "viewer", "100%", "100%", "7", "#000000"&#41;;    
     fo.addParam&#40;"wmode", "transparent"&#41;
     fo.write&#40;"flashcontent"&#41;; 
</script>    

And that's the XML-Code:

<?xml version="1.0" encoding="UTF-8"?>
<simpleviewerGallery maxImageWidth="480" maxImageHeight="480" textColor="0x000000" frameColor="0x000000" frameWidth="20" stagePadding="40" thumbnailColumns="3" thumbnailRows="1" navPosition="bottom" title="Werkstatt" enableRightClickOpen="true" backgroundImagePath="werkstatt/.jpg" imagePath="" thumbPath="">
<image>
    <filename>1.jpg</filename>
    <caption></caption>    
</image>

Please help me  :oops:

Re: Transparent background

Not sure if this is the problem or just a post mistake; you have typo in the above code:

var fo = new SWFObjec&#40;"viewer.swf", "viewer", "100%",

Should be:


var fo = new SWFObject&#40;"viewer.swf", "viewer", "100%",

Re: Transparent background

Ohhh Sorry! That's just a post mistake.


that's my code:

var fo = ew SWFObject&#40;"viewer.swf", "viewer", "100%",

Re: Transparent background

whats the URL?

Felix Turner
SimpleViewer Support Team.

Re: Transparent background

I also noticed that although you are after a transparent background although you have specified a jpg in your XML file as the background. This seems to me to be slightly contradictory.

My code in php file:

<script type="text/javascript"> 
var fo = new SWFObject&#40;"../viewer.swf", "viewer", "790", "570", "7", "#000000"&#41;; 
fo.addParam&#40;"wmode", "transparent"&#41;
fo.write&#40;"flashcontent"&#41;; 
</script> 

My Code in xml File:

<?xml version="1.0" encoding="UTF-8"?>
<simpleviewerGallery maxImageWidth="480" maxImageHeight="480" textColor="0xFFFFFF" frameColor="0xFFFFFF" frameWidth="1" stagePadding="5" thumbnailColumns="3" thumbnailRows="6" navPosition="left" title="" enableRightClickOpen="false" backgroundImagePath="" imagePath="images/" thumbPath="thumbs/">
<image>
    <filename>brocky-02.jpg</filename>
    <caption></caption>    
</image>

hope that this helps some more, if not post your url so we can have  closer look.

smile

Re: Transparent background

I figured it out.

To make the simpleviewer background transparent with an iframe, you have to go to the simpleviewer index.html file. Half way down in the code look for "body" you have to delete the lines for background-color.

Then under:
var fo = new SWFObject("viewer.swf", "viewer", "100%", "100%", "7", "#000000");

Add this:
fo.addParam("wmode","transparent");

In all the posts I have read about adding "wmode", "transparent" , no one mentioned that you have to delete the line regarding background-color. It took a few hours until I got lucky and took a guess at deleting that line.

Hope this helps others,
Jay W

Re: Transparent background

Sorry this dosn't work!!!!  :?

index.html:

    <script type="text/javascript">
        var fo = new FlashObject&#40;"viewer.swf", "viewer", "100%", "100%", "7", "#181818"&#41;;        
                fo.addParam&#40;"wmode", "transparent"&#41;;
        fo.addParam&#40;"quality", "best"&#41;;
        fo.write&#40;"flashcontent"&#41;;    
    </script>

gallery.xml:

<?xml version="1.0" encoding="UTF-8"?>
<simpleviewerGallery maxImageWidth="480" maxImageHeight="480" textColor="0xFFFFFF" frameColor="0xffffff" frameWidth="20" stagePadding="40" thumbnailColumns="3" thumbnailRows="3" navPosition="left" title="SimpleViewer Title" enableRightClickOpen="true" backgroundImagePath="" imagePath="" thumbPath="">
<image>
...

please help me!!!!!   :oops:

Re: Transparent background

The code that you posted looks correct. Make sure you also do this. In the simpleviewer index.html page find the section of code that says:

body &#123;

        height&#58; 100%;

        margin&#58; 0;

        padding&#58; 0;

        background-color&#58; #181818;

        color&#58;#ffffff;
&#125;

then delete the code about color so that the sections looks like this:

body &#123;
        height&#58; 100%;
        margin&#58; 0;
        padding&#58; 0;    
    &#125;

Re: Transparent background

I would also suggest specifying directories for your images and thumbnails otherwise they wont display, a thumb needs to have the same filename as the full sized image otherwise it barfs at you.
So from your code snipet it looks like you just have everything in the current directory which ( well as far as I know ) wont work.

smile

Re: Transparent background

Thanks for help.  big_smile

But why are the background now white  :?:

Look there:

malerfachbetrieb.ch/home.php?site=werkstatt

Re: Transparent background

OK so I haven't looked at the source yet, but it works OK in Firefox. Just not in Internet Exploder. I have version 7.0 installed which version of Exploder are you using?

Cheers,

DAVE

smile

Alright, now I have looked at the source and the only real difference that I can see is in the script that calls flashviewer.

Where you have ...
[code]var fo = new FlashObject&#40;"viewer.swf", "viewer", "100%", "100%", "7", ""&#41;;       
fo.addParam&#40;"wmode", "transparent"&#41;;
[/code]

I have ...
[code]var fo = new SWFObject&#40;"../viewer.swf", "viewer", "790", "570", "7", "#000000"&#41;;
fo.addParam&#40;"wmode", "transparent"&#41;
[/code]

OK so the only thing that I can see that is really different is that in the first line you have blah blah blah,"7",""); and I have blah blah blah,"7","#000000");

I would try putting in the #000000 and see what happens. Either that or just tell everyone that is going to look at your site to use Firefox. big_smile just kidding.

DAVE

smile
[/code]

Re: Transparent background

I have IE 7
why It dosn't work?

Re: Transparent background

I'm sorry mate off the top of my head I don't know.

IE and firefox render web pages differently.

Usually if you write a webpage to work in Firefox it will work in IE, but not always. Did you try my suggestion? What happened?

Cheers,

DAVE

smile

Re: Transparent background

Your correction unfortunately shows no change. Which is to still try

Re: Transparent background

Hey all,
I had a problem using my background with autoviewer (but this applies to simpleviewer as well). I embedded it in a gallery in my wedding website...but I forgot to upload the CSS style sheet into the gallery directory (so my references were screwed up). Works great now, just a heads to anyone who is combining CSS with the viewers.

P

Re: Transparent background

Seamus,

   I was just wondering if you ever got things to work the way you wanted them to? I've just a had a quick peek at the website and it is looking good.

Dave

smile

Re: Transparent background

I have created a gallery using Simpleviewer and searched for a way to make the background transparent.  This forum has been very helpful!  I make all of the adjustments mentioned in this post, but I am having the same problem mentioned previously.  With the adjustments, the gallery works great in Firefox, but has a white background in Internet Explorer.  Did anyone ever find a fix for this?  Thanks in advance.

Re: Transparent background

What's your url?

DAVE

smile

Re: Transparent background

fishontours DOT com/gallery DOT h t m l

If you check and it has a blue background it is because I have replaced the index.html with one that passes for both IE and Firefox with the same color scheme.  The entire site is built on a "transparent" theme, so that is why I want to get the gallery setup as transparent.