Topic: "PostcardViewer requires the lastest Flash Player"

I have a PowerBookG4 OsX 10.4 updated with the lastest versions, basically i got Safari, Firefox, IE for Mac, everything. Plus i have Flash 9 installed on my MAC also updated, i did the Postcard Gallery on Photoshop CS2 and when am triying to open the file on any browser with i see is

"PostcardViewer requires the lastest Flash Player" [/b]

So, i can't see any Gallery made for me, what is the problem, what am doing wrong? even i did the Flash Test Version and i got all Updated.