Topic: Macromedia Flash

I have tried the free version of SimpleViewer and now wish to buy the Pro version.  However, the web site says "SimpleViewer-Pro requires Macromedia Flash MX04 (version 7.2 or later) authoring software to customize. "  Is this true??  This is a $700 program, and I'm not going to spend that much just to run a $45 program.  I must be missing something here.  Thanks!