Topic: Wierd bug - only 8 images showing

I have a 24 image photo gallery with the thumbs set to one row with 4 thumbs on display per time.

So after a lot of customisation, 1 large image will have 4 thumbs under it and the mini 'next' button then takes me to the next 4 thumbs and so on.

I just noticed though that I can click 'next' only twice whereupon clicking next will bring me back to the start of the gallery again.

I'm not sure why because all the images are set up correctly with the proper path and images name. I KNOW this because clicking the large NEXT button over the large image successfully shows me the full 18 large images.

Any ideas?

Sample here
http://www.bradyshipmanmartin.ie/test/l … _index.php

Thanks[/img]

Re: Wierd bug - only 8 images showing

Seems to be working ok now. Try clearing your cache to see the latest version.

Felix Turner
SimpleViewer Support Team.

Re: Wierd bug - only 8 images showing

No it's not a caching image. I'm talking about the small square buttons beside the thumbnails.

I've just noticed that if you hove over the 'next' button after the first 4 thumbs that it's actually the 'back' button that gets triggered and highlights.

Any ideas why this might be and how to fix?

Re: Wierd bug - only 8 images showing

Looks to me like the next and previous buttons are overlapped.  In the FLA source file, both buttons have a large active clicking area.  So, when you think you are clicking in next, the previous is on top making the thumbs cycle previous instead.