Topic: X's Displayed...

When viewing my image viewer, everything shows. However, where the photos are supposed to be, there are white X's displayed. I have checked my image paths and they are correct. When I click on the "Index" file that is saved on my computer, it also shows the X's. Im thinking there is something wrong with my image paths, however, I copied and pasted them right from the location.

Can anyone help me in determining what is wrong?
Thanks!

Re: X's Displayed...

I forgot to add... Do I need to add in a location for imagePath="" thumbPath="" in the gallery.xml file? If so, how do I go about doing that if the files are saved on my computer.

Re: X's Displayed...

You do not need to set image or thumb path if your files are in the default location.

i.e.

your_gallery_folder
.........images
.........thumbs
.........gallery.xml
.........index.html
.........swfobject.js
.........viewer.swf

Your gallery.xml should look something like this:

<?xml version="1.0" encoding="UTF-8"?>

<simpleviewerGallery maxImageWidth="787" maxImageHeight="525" textColor="0xFFFFFF" frameColor="0xFFFFFF" frameWidth="4" stagePadding="30" thumbnailColumns="4" thumbnailRows="4" navPosition="left" title="Wedding Gallery" enableRightClickOpen="false" backgroundImagePath = "background.jpg">

<IMAGE>

    <NAME>WA000001.jpg</NAME>

    <CAPTION>Image 1/101</CAPTION>

</IMAGE>

and you index.html like this:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http&#58;//www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<!-- saved from url=&#40;0014&#41;about&#58;internet -->

<html xmlns="http&#58;//www.w3.org/1999/xhtml" xml&#58;lang="en" lang="en">

<head>

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />

<title>Phillip Norman Photography - Wedding Gallery</title>

<!-- Download SimpleViewer at www.airtightinteractive.com/simpleviewer -->

<script type="text/javascript" src="swfobject.js"></script>

<style type="text/css">    

    /* hide from ie on mac */

    html &#123;

        height&#58; 100%;

        overflow&#58; hidden;

    &#125;

    #flashcontent &#123;

        height&#58; 100%;

    &#125;

    /* end hide */

    body &#123;

        height&#58; 100%;

        margin&#58; 0;

        padding&#58; 0;

        background-color&#58; #333333;

        color&#58;#ffffff;

    &#125;

</style>

</head>

<body>

    <div id="flashcontent">SimpleViewer requires Macromedia Flash. <a href="http&#58;//www.macromedia.com/go/getflashplayer/">Get Macromedia Flash.</a> If you have Flash installed, <a href="index.html?detectflash=false">click to view gallery</a>.</div>    

    <script type="text/javascript">

        var fo = new SWFObject&#40;"viewer.swf", "viewer", "100%", "100%", "7", "#333333"&#41;;    

        fo.addVariable&#40;"preloaderColor", "0xffffff"&#41;;

        fo.addVariable&#40;"xmlDataPath", "gallery.xml"&#41;;    

        fo.write&#40;"flashcontent"&#41;;    

    </script>    


</body>

</html>
Regards
Phil
http://www.phillipnorman.com