Topic: Images not showing up on website

Hello, this is my first time using Simpleviewer. I did everything the instructions said but I cannot get the images to show up on my website. I see the squares but no images. Please help.

Thanks, Ivy

Re: Images not showing up on website

Please check the FAQ, Q3: http://www.airtightinteractive.com/simp … r/faq.html

Felix Turner
SimpleViewer Support Team.

Re: Images not showing up on website

I have checked the FAQ's and it's of no help. The first picture is showing up (thumb and original) but none of the others are. The code is the same for the rest of the pics. Here's what I have:

<?xml version="1.0" encoding="UTF-8"?>
<SIMPLEVIEWER_DATA maxImageDimension="480" textColor="0xFFFFFF" frameColor="0xFFFFFF" bgColor="0x000000" frameWidth="20" stagePadding="40" thumbnailColumns="3" thumbnailRows="3" navPosition="right" navDirection="LTR" title="A Day in Elizabeth Park" imagePath="" thumbPath="">

<IMAGE>
    <NAME>SoftRose.jpg</NAME>
    <CAPTION>Soft Rosie</caption>
</IMAGE>
<IMAGE>
    <NAME>Picture028.jpg</NAME>
    <CAPTION>Trip to the Pond</caption>
</IMAGE>
<IMAGE>
    <NAME>Picture029.jpg</NAME>
    <CAPTION>Into the Woods</caption>
</IMAGE>
<IMAGE>
    <NAME>Picture031.jpg</NAME>
    <CAPTION>Pink Dreams</caption>
</IMAGE>
<IMAGE>
    <NAME>Picture032.jpg</NAME>
    <CAPTION>Twin Beauties</caption>
</IMAGE>
<IMAGE>
    <NAME>Picture034.jpg</NAME>
    <CAPTION>Flourished Red Rose</caption>
</IMAGE>
<IMAGE>
    <NAME>Picture036.jpg</NAME>
    <CAPTION>Sunny Peach</caption>
</IMAGE>
<IMAGE>
    <NAME>Picture037.jpg</NAME>
    <CAPTION>Old Glory Peeking</caption>
</IMAGE>
<IMAGE>
    <NAME>Picture038.jpg</NAME>
    <CAPTION>Blossomed Red Rose</caption>
</IMAGE>
<IMAGE>
    <NAME>Picture039.jpg</NAME>
    <CAPTION>Cottonball</caption>
</IMAGE>
<IMAGE>
    <NAME>Picture041.jpg</NAME>
    <CAPTION>Cherished Friendship</caption>
</IMAGE>
<IMAGE>
    <NAME>Picture042.jpg</NAME>
    <CAPTION>Proud One</caption>
</IMAGE>
<IMAGE>
    <NAME>Picture046.jpg</NAME>
    <CAPTION>Happy Orchids</caption>
</IMAGE>
<IMAGE>
    <NAME>Picture048.jpg</NAME>
    <CAPTION>Four of a Kind</caption>
</IMAGE>
<IMAGE>
    <NAME>Picture049.jpg</NAME>
    <CAPTION>Dirt Road</caption>
</IMAGE>
<IMAGE>
    <NAME>Picture050.jpg</NAME>
    <CAPTION>High Whispers</caption>
</IMAGE>
<IMAGE>
    <NAME>Picture051.jpg</NAME>
    <CAPTION>Droopy Spots</caption>
</IMAGE>
<IMAGE>
    <NAME>Picture056.jpg</NAME>
    <CAPTION>Bells in the Green</caption>
</IMAGE>
<IMAGE>
    <NAME>Picture057.jpg</NAME>
    <CAPTION>Pacific Pond</caption>
</IMAGE>
<IMAGE>
    <NAME>Picture058.jpg</NAME>
    <CAPTION>Ducks under Bridge</caption>
</IMAGE>
<IMAGE>
    <NAME>SoftOrchid.jpg</NAME>
    <CAPTION>Soft Orchid</caption>
</IMAGE>
<IMAGE>
    <NAME>Picture026.jpg</NAME>
    <CAPTION>Sculpture</caption>
</IMAGE>

</SIMPLEVIEWER_DATA>

Re: Images not showing up on website

Do the images show on your local machine? If not, your images are probably not saved as 'non-progressive'. If they do, check the letter case of your filenames.

From the FAQ, Q3:

3. My images show locally, but not when I upload them to my webserver. What are possible problems?

Check your image paths and filenames exactly match the names specified in the XML file. Most servers are Case Sensitive. This means the letter cases in the filename must exactly match those in the XML document.

Another possible problem is if your webserver has  'Hotlink Protection' enabled. Hotlink Protection breaks SimpleViewer. Check with your webserver administrator.

Felix Turner
SimpleViewer Support Team.

Re: Images not showing up on website

Using paintshop pro 9 how do I save as Non progressive


the save options are...

Lossless encoding
Progressive encoding
Standard encoding


Which is Non progressive??

Re: Images not showing up on website

Just been told "lossless"

Correct?

Re: Images not showing up on website

Usually when you see the square and no image, mean you are 1/2 way there. You've gotten the path set correctly to read the swf file. But you have not or might have not put the path correctly to read the thumbnails and pictures..

Have you checked it? Look at both the XML file and the index file you used to ensure you've use the correct path assignment.

I've noticed this from your code above...

<SIMPLEVIEWER_DATA maxImageDimension="480" textColor="0xFFFFFF" frameColor="0xFFFFFF" bgColor="0x000000" frameWidth="20" stagePadding="40" thumbnailColumns="3" thumbnailRows="3" navPosition="right" navDirection="LTR" title="A Day in Elizabeth Park" imagePath="" thumbPath=""> 

The image path and thumbpath are blank. Did you set it in the original file?

You could use something like http://www.domainname.com/picture/images/ and http://www.domainname.com/picture/thumbs/ for these and it will work...

also check the index file you are using as well..

Here is a sample i am using on mine...

<SIMPLEVIEWER_DATA maxImageDimension="480" textColor="0xFFFFFF" frameColor="#000000" bgColor="0x181818" frameWidth="5" stagePadding="40" thumbnailColumns="3" thumbnailRows="3" navPosition="right" navDirection="LTR" title="My Little Puppy - Fritz" imagePath="http&#58;//www.knguyentu.com/pictures/fritz/images/" thumbPath="http&#58;//www.knguyentu.com/pictures/fritz/thumbs/">
[url]http://www.photographybykevin.net[/url]

Simple Viewer FAQ By Kevin
[url]http://knguyentu.com/wordpress/photography-by-kevin/simpleviewer-flash-photo-gallery/[/url]

Re: Images not showing up on website

I was having this same problem up until a few minutes ago.
I am uploading via Server-side Script (PHP version).


If you're sure that:

- It's not your cache.
- Your images are saved as 'non-progressive'.
- Your xml is correct.
- And your webserver is not 'hotlink protected'.

Then the reason your images are not showing up and just displays the little squares may be because of
your File Persmission settings.

7. Set file permissions
Set file permissions on the build script to 'execute'. Set file permissions on imageData.xml and thumbs folder to 'write'. You can do this with your FTP program, check the documentation.

I had to play with this a little bit, but it definitely solved the problem.