Topic: Problem with tags

I've just purchased Tiltviewer-Pro and I'm in the process of making some test. I wan't to do 3 galleries with 3 different sets of tags from Flickr. But the tag doesn't seem to work. When I set the the viewer with tags, the pictures never load. I've double check and there's no mistake in the tags.

Here's the vairable, and yes the tag is "showdesign".

fo.addVariable("tags", "showdesign");

Thanks

Re: Problem with tags

You need at least the first 3 (maybe all 4) of these variables in your html file:

fo.addVariable("useFlickr", "true");
fo.addVariable("user_id", "12345678@N00");
fo.addVariable("tags", "showdesign");
fo.addVariable("tag_mode", "all");

In above, you'll need to replace your user_id value with your own.  Aside from that, make sure the XML Gallery variables are commented.

Re: Problem with tags

I've done that, it's when I put tags that it bugs.

fo.addVariable("useFlickr", "true");
fo.addVariable("user_id", "7244211@N02");
fo.addVariable("tags", "showdesign");
fo.addVariable("tag_mode", "all");

You can see what it does here:

funkee. net/ test/ designtilt.html

Re: Problem with tags

Retag your photos on flickr.  http://flickr.com/photos/funkeephil/tags/showdesign/  ... says FunkeePhil doesn't have any photos tagged with showdesign, but other people do.

Re: Problem with tags

You might also want to look at permissions on flickr - maybe you have them set to private.

Re: Problem with tags

It's weird because I see the tags on my flickr, and retag them 2 times already. sad Oh the permissions are set to public.

Re: Problem with tags

I'm not sure what's going on ... but when I click on most of your tags, I get FunkeePhil doesn't have any photos tagged with xxxxx.  Out of the 30 or so tags you have shown here, http://flickr.com/photos/funkeephil/tags/, only a few actually show pics.  I'll leave this to someone else who knows flickr better.

Re: Problem with tags

Looks like tags are not updated instantly on Flickr. So you may have to wait a while before your new tags show up.

Felix Turner
SimpleViewer Support Team.

Re: Problem with tags

Yeah but even with the tags that been there since 1 year ago it doesn't work.

Re: Problem with tags

When you click on your tags, do you have any that throw the error about you not having any photos tagged with that name, or do they show for you?  If they do show, then I'm still betting on a permissions thing.  What about safety filter setting?  I don't know if tiltviewer cares about safety level though. Also look at content type.. again, I don't know if tiltviewer cares if the photos are set as content=photos, or if changing that to screenshot or illustration would cause an error.

Re: Problem with tags

On flickr I don't have any problem with my tags, everything is correct. And the permissions and filter are all set to public et safe.

I've just tried for fun to search the tag "showdesign" with Flickr Related Tag Browser on your site and it worked fine. Why now does Tiltviewer doesn't respond to my tags.

Re: Problem with tags

It's working now.  When I go to flickr and click your showdesign tag, I now see pics.  Also, tiltviewer is picking up the photos.  I am hosting it here:

http://<removed>

View the page source if you want to compare my options with what you have.  I don't know if you changed anything on flickr, but it definitely wasn't working before.  If I can't click on your tag on flickr's site and have it show me the pics, it will never show up in tiltviewer.

Re: Problem with tags

That's really weird *X-Files music*. The code that you used is the same as mine. Well since it's working now cool and thanks for the help. smile I presume it was Flickr that was buggy. Who knows.