1

Topic: caption text problem on first image

I've used Autoviewer in the website of our local photography club. It works like dream except for one thing: On every first image of a gallery the caption tekst (in this case: the photographers name) is placed on the left but lower than the image counter in the right corner. This only happens on the first image. On the rest of the images caption and counter are on the same height. When I run the Autoviewer demo this doesn't happen. When I compare the XML files I find no differences. Does anyone know how to fix this?

EDIT: I've once more been checking my xml-file against the example file that comes with the download. I now know what the problem is, but not how to fix it: I don't use a title for the gallery (title="" on the second line of the XML-file). But the viewer does expect a title and still reserves space to show it. Removing the "title=" statement is not a good option because the viewer will display the word "Undefiined" which looks even worse...
Is there any way to make Autoviewer work without showing a title?

Re: caption text problem on first image

I have struggled with the exact same problem.
The only solution I have found is to manually edit the file gallerydata.xml. You will have to do this every time you re-generate the gallery.

Suppress the the text for the title field in
Change this:
<gallery title="web" frameColor="0xFFFFFF" frameWidth="2" imagePadding="30" displayTime="6">

to

<gallery title="" frameColor="0xFFFFFF" frameWidth="2" imagePadding="30" displayTime="6">

And the text disapears !

You can also suppress the image names by editing the file imageNode.xml in the template directory (in my case Picasa2webtemplatesautoviewer_picasa_template)

Suppress the variable tag between <caption> and </caption>

3

Re: caption text problem on first image

Suppress the the text for the title field in to
<gallery title="" frameColor="0xFFFFFF" frameWidth="2" imagePadding="30" displayTime="6">
And the text disapears !

Thank you very much for your reply. I tried this allready (see edited text of my first message. This works OK for not showing the gallery title, but the space itself is still reserved. Since I do use a caption text for the image itself, the caption is displayed lower than on all other images.
I wonder if It is possible to remove the gallery title (and the space that is reserved for the title completly. And if this is not possible in the free version, can it be done in the Pro-version (by someone who is not very code - savy)

Re: caption text problem on first image

i don't know if youll get an option.as in simpleviewer basic if it is the case then try to set the variable.

static var showTitle&#58;Boolean = false; 

it works fine in pro version...