Topic: simnpleviewer won't display on Macs, Safari or Firefox

What's the cause of this and how do you resolve it? My gallery works fine on Internet Explorer on a PC. But, if I go to a mac, the gallery never, appears like it has attempted to load. Additionally, in Firefox on a PC, the simpleviewer gallery is nowhere near the size it's suppose to be and is chopped off across the bottom.

Is there some code to resolve these two issues.

Thanks!

Re: simnpleviewer won't display on Macs, Safari or Firefox

ok, I got Firefox working properly by chaning the % sizes int eh div to acutal numbers. That's solved now. My biggest issue is whywon't this work on a Mac or Safari?

Re: simnpleviewer won't display on Macs, Safari or Firefox

I imagine you have an issue with the HTML code you are using to embed SimpleViewer. Does the demo page work for you?: http://www.airtightinteractive.com/photos/

Try working from the index.html file that comes with the download.

Felix Turner
SimpleViewer Support Team.

Re: simnpleviewer won't display on Macs, Safari or Firefox

Felix, thanks for your response. I don't have a MAC handy but I can check on one tomorrow. I actually used the demo page to get my gallery working in Firefox properly. however, I'm still concerned about Safari. I don't know if the changes I made will fix safari or not without locating a mac to check it on. basically what i did to get firefox working was to copy the div code from the demo page to my index.html file where I ahve the gallery embeddded and then I updated my css file to look like the css code at the top of the demo page.

do you think that will fix it in Safari as well?

Thanks again!
Buster

Re: simnpleviewer won't display on Macs, Safari or Firefox

I too am having an issue with Macs.

The page I created has worked since April when the site was created, now all of a sudden it does not load.  I can view other SimpleViewer pages fine, just not my own.  It tries to redirect me to a URL graphics/upgrade.html instead of graphics/index.html.

The page works in Firefox and IE on PCs, but not on Safari or Firefox on Macs.

Any suggestions?

Re: simnpleviewer won't display on Macs, Safari or Firefox

Please check the FAQ, Q2: http://www.airtightinteractive.com/simp … r/faq.html

Felix Turner
SimpleViewer Support Team.

Re: simnpleviewer won't display on Macs, Safari or Firefox

All of that info is there already.

<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>SimpleViewer</title>
<style type="text/css">
<!--
html, body &#123;
    /* */
    height&#58;100%;
    /* hide from Mac IE 5.x */ 
    background-color&#58; #181818;
    margin&#58; 0;
    padding&#58; 0;
    border&#58; 0;
    overflow-y&#58; hidden;
&#125; 
-->
</style>
<!-- saved from url=&#40;0014&#41;about&#58;internet -->
<script language="javascript" type="text/javascript" src="flash_detect.js">
    <!--
    function getFlashVersion&#40;&#41; &#123; return null; &#125;;
    //-->
</script>
    
<script language="javascript" type="text/javascript">
    <!--
    var flashVersion = getFlashVersion&#40;&#41;;
    if &#40;flashVersion < 6&#41; &#123;        
        location.replace&#40;"upgrade.html"&#41;;
    &#125;
    //-->
</script>    
</head>

That is what it looks like between the head tags.

Re: simnpleviewer won't display on Macs, Safari or Firefox

I too am having an issue with Macs.

The page I created has worked since April when the site was created, now all of a sudden it does not load.  I can view other SimpleViewer pages fine, just not my own.  It tries to redirect me to a URL graphics/upgrade.html instead of graphics/index.html.

The page works in Firefox and IE on PCs, but not on Safari or Firefox on Macs.

I started looking into SimpleViewer after seeing it on a couple of sites. Since last week (July 22 '06), when I return to these sites the gallery will not load. The page redirects to upgrade.html. I can confirm that this is happening after the last upgrade to Firefox on the Mac and that the sites do play properly in IE6 and Firefox 1.0.3 on the PC. I'm wondering if this type of problem might affect sites again in the future.

Re: simnpleviewer won't display on Macs, Safari or Firefox

I found that this recommended course of action fixed my problems with the following caveat:

The updated version of the index file did not mirror the replacement code in the FAQ, specifically the last bit of Javascript.

I had to replace this:

    <script type="text/javascript">
        var fo = new SWFObject&#40;"viewer.swf", "viewer", "100%", "100%", "7", "#181818"&#41;;    
        fo.addVariable&#40;"preloaderColor", "0xffffff"&#41;;
        fo.addVariable&#40;"xmlDataPath", "gallery.xml"&#41;;    
        fo.write&#40;"flashcontent"&#41;;    
    </script>    

with this:

     
        <script type="text/javascript">
         var fo = new SWFObject&#40;"viewer.swf", "viewer",
 "100%", "100%", "7", "#181818"&#41;;       
                fo.addVariable&#40;"xmlDataPath", "imageData.xml"&#41;;
         fo.write&#40;"flashcontent"&#41;;       
        </script> 

This seems to have fixed the problem.

Re: simnpleviewer won't display on Macs, Safari or Firefox

hi,

From a end-user's(meaning: visitors and guest to the simpleview gallery) POV, I have been experiencing the same problem just because i am a mac user.
I get directed to a page that asks me to update my flash player when my flash player is the most updated version. The strange thing is, I am able to access galleries that are still using simpleviewer 1.7. Also i am able to see the gallery here.

Any ways to resolve the problem so that end-users will not encounter this problem anymore? Cheers.