Topic: Another AV Pro 1.4 and Lightroom question

I'm using AV Pro 1.4 and Lightroom 1.4 on a Mac.  I've read through all of the documentation, including Q7 in the FAQ.  However, I still haven't been able to solve my problem.

My question specifically is whether it's possible to upgrade the TTG Lightroom AutoViewer template to the Pro version of AutoViewer 1.4.  TTG AutoViewer Gallery already exports as AV 1.4, so in theory this should be possible, right?

In the SimpleViewer documentation, you provide instructions for how to replace the "viewer.swf" file in the Lightroom web galleries>templates folder.      Can I do something similar with AutoViewer?  The problem seems to be that the AutoViewer 1.4 "index.html" file exported by the TTG AutoViewer gallery still refers to "flashobject" instead of "swfobject".  So I would still have to manually change these links in the "index.html" file, even if I replaced the "autoviewer.swf" file in the TTG Template with the "autoviewer.swf" file from the Pro version of AV 1.4 that I purchased.

I hope this is making sense.  Basically, how can I use AV 1.4 Pro with Lightroom?

Re: Another AV Pro 1.4 and Lightroom question

To use AutoViewer-Pro v1.4 with the TTG Lightroom AutoViewer template you just need to swap out the SWF file in the template folder with the one in the Pro download.

Felix Turner
SimpleViewer Support Team.

Re: Another AV Pro 1.4 and Lightroom question

That's what I thought, but the SWF file in the template folder is called "viewer.swf", whereas the one in the Pro folder is called "autoviewer.swf".  Won't that cause problems?

Re: Another AV Pro 1.4 and Lightroom question

are you using the latest TTG plugin?

Felix Turner
SimpleViewer Support Team.

Re: Another AV Pro 1.4 and Lightroom question

I have the exact same issue. I have searched the Forums and written multiple emails and still cannot update my AutoViewer Lightroom Template to AutoViewer Pro.

I copied the autoviewer.swf file from my purchased version of AutoViewer Pro and attempted to paste it exactly as described below:

4.2 Upgrading the Lightroom AutoViewer Template

To upgrade your Lightroom v2 AutoViewer Engine to AutoViewer-Pro:

    * Copy the AutoViewer SWF that comes in the Pro download (at \web\autoviewer.swf) into the AutoViewer Engine folder, replacing the existing file.The path to the AutoViewer Engine folder is as follows:
          o Windows: C:\Program Files\Adobe\Adobe Photoshop Lightroom 2\shared\webengines\autoviewer.lrwebengine
          o Macintosh:Applications/Adobe Lightroom 2.app/Contents/Plugins/Web.lrmodule/Contents/Resources/galleries/autoviewer.lrwebengine (To browse inside a package use ctrl-click and select "Show Package Contents").
    * Restart Lightroom. Any galleries you create from now on will use the Pro swf.

After restarting Lightroom, there was no difference in the web gallery settings. I then deleted the original viewer.swf file leaving only the recently updated autoviewer.swf. I restarted Lightroom once again and when I tried to open the AutoViewer in the web module, the gallery would not respond. The loading bar kept flashing rapidly as if it were missing a file to continue to load the gallery. It was not until I replaced the original viewer.swf file that the web gallery responded, but obviously with the original appearance.

Is there anything that I can do?

Re: Another AV Pro 1.4 and Lightroom question

I have the exact same issue. I have searched the Forums and written multiple emails and still cannot update my AutoViewer Lightroom Template to AutoViewer Pro.

I copied the autoviewer.swf file from my purchased version of AutoViewer Pro and attempted to paste it exactly as described below:

4.2 Upgrading the Lightroom AutoViewer Template

To upgrade your Lightroom v2 AutoViewer Engine to AutoViewer-Pro:

    * Copy the AutoViewer SWF that comes in the Pro download (at \web\autoviewer.swf) into the AutoViewer Engine folder, replacing the existing file.The path to the AutoViewer Engine folder is as follows:
          o Windows: C:\Program Files\Adobe\Adobe Photoshop Lightroom 2\shared\webengines\autoviewer.lrwebengine
          o Macintosh:Applications/Adobe Lightroom 2.app/Contents/Plugins/Web.lrmodule/Contents/Resources/galleries/autoviewer.lrwebengine (To browse inside a package use ctrl-click and select "Show Package Contents").
    * Restart Lightroom. Any galleries you create from now on will use the Pro swf.

After restarting Lightroom, there was no difference in the web gallery settings. I then deleted the original viewer.swf file leaving only the recently updated autoviewer.swf. I restarted Lightroom once again and when I tried to open the AutoViewer in the web module, the gallery would not respond. The loading bar kept flashing rapidly as if it were missing a file to continue to load the gallery. It was not until I replaced the original viewer.swf file that the web gallery responded, but obviously with the original appearance.

I just redownloaded what I believed to be the latest version of TTG AutoViewer. Loaded in Lightroom it says TTG AutoViewer Gallery 1.2 But I have seen other peoples posts about a version 1.4. I have tried searching to be able to update my version to 1.4 hoping that would solve my problem, but every link to 1.4 updates are dead. Please point me in the direction I need to go.

Thanks!

Is there anything that I can do?

Last edited by Brewerphoto (2010-06-20 06:47:54)

Re: Another AV Pro 1.4 and Lightroom question

@Brewerphoto

After restarting Lightroom, there was no difference in the web gallery settings.

Updating the SWF used by the plugin does not give you any extra settings in Lightroom. All that updating the plugin accomplishes is any galleries you make now will use the pro swf. If you want to set the pro settings you will either have to edit the gallery.xml for each gallery you produce or you will have to edit the plugin to add the pro features.

Mike Richards
SimpleViewer Support Team.