Topic: Support Felix? Next/Previous Buttons don't work

Hi, love the slideviewer, shame so many questions go unanswered!

I have a div layer over my slideviewer that has to be there in order to keep content positioned correctly when resizing the browser window. For some strange reason having a layer over the viewer (I have utilised "wmode", "opaque") stops the next and previous buttons from functioning although they appear and disappear as you roll over. Can't understand why one function of the button (i.e. show/hide) works but not the other (move to next/previous image).

Any clues please??

Re: Support Felix? Next/Previous Buttons don't work

Using "wmode" seems to give Firefox a headache.
For me, when using "wmode" (opaque or transparent), all buttons (including thumbnails) were very temperamental in Firefox 3 but worked fine in IE7.
I'm using the SimpleViewer skin for JAlbum and the solution for me was to remove the line "overflow-x: auto;" in the CSS declaration for "html" and "body".
Hope this helps.

Steven Speirs
SimpleViewer Support Team.

Re: Support Felix? Next/Previous Buttons don't work

Hi Monkeyboy, thanks for taking the time out to post.

Unfortunately there is only one line related to overflow in html (overflow: hidden;) and this doesn't seem to have any effect when removed.

Thanks again for responding

Re: Support Felix? Next/Previous Buttons don't work

No worries.  Was worth a shot, I guess.

For what it's worth, I've just tried SimpleViewer 1.85 with SWFObject 2.1, Flash Player 10.0.0.525 (beta 2) and Firefox 3.1 (alpha 1) and, with the "overflow-x: auto;" line, I still have exactly the same issues with wmode in Firefox (still OK in IE7).
Not so much a problem for me (as I can easily remove this line with seemingly no side-effects), more of a curiosity.

Just out of interest, colectic, which browser(s) do your problems appear in?

Steven Speirs
SimpleViewer Support Team.

Re: Support Felix? Next/Previous Buttons don't work

as far as I know it's all of them.

address is dubdubdubdot newmediatree dot com slash test slash guezmode

as you will see the left hand beige box is the reason behind having a div layer over the top, it's the only way I can find to keep it positioned correctly when resizing the browser window (i.e. there is a table inside a 100% div layer).

I may have missed something obvious and be able to achieve this positioning without the div covering the viewer, not sure?

Re: Support Felix? Next/Previous Buttons don't work

sorry you will need to navigate to any of the sections; kitchens living rooms etc

Re: Support Felix? Next/Previous Buttons don't work

Sorry I can't be of any more help.
I've taken a look at your code but keeping everything positioned correctly when resizing the browser window is way beyond my very basic knowledge!
It's definately the beige box div causing the problem, though. Remove the div and the navigation arrows work fine.

Steven Speirs
SimpleViewer Support Team.

Re: Support Felix? Next/Previous Buttons don't work

Yep that's what I concluded. Thanks for looking anyway