Topic: Title Font Problem

I've tried the code in FAQ, Q15 - and it's not working. When I put the code in and open my gallery, nothing shows up.

What am I doing wrong? What I want to do is make my title Times, 26pt and #D5C19B in color. I tried to just test it with the Times font first like this:

title="<font face="Times">My Gallery</font>"

What is wrong here?

Thanks for any help!

Re: Title Font Problem

Try:

title="&lt;font face="Times" size="26" color="#d5c19b"&gt;My Gallery&lt;/font&gt;"

All ', ", &, < and > characters within the title quotes must be written as &apos;, ", &amp;, &lt; and &gt; respectively.

The above code will force the color of the title to be #d5c19b.
Any captions will still be in the color specified by the "textColor" option.

If you are happy enough for the color of the title and any captions to be the same, you can use:

textColor="0xd5c19b"
title="&lt;font face="Times" size="26"&gt;My Gallery&lt;/font&gt;"
Steven Speirs
SimpleViewer Support Team.

Re: Title Font Problem

title="&lt;font face="Times" size="26" color="#d5c19b"&gt;My Gallery&lt;/font&gt;"

Thanks! I cut and pasted the code above did all the formatting except for the font color.

I changed the textColor to the color I wanted the title in and all of the text changes as you indicated.

I don't really want that. I want the title to be different from the captions.

Thanks for any help!

Re: Title Font Problem

textColor="0xd5c19b"


will select a default color for all text.

If you do something like:

title="&lt;font color="#0000ffb"&gt;My Gallery&lt;/font&gt;" 

This will force the title to be color #0000ff and will leave the captions to be in the default color as specified by textColor.

You can also force the color of the captions to something other than the default by using something like:

<IMAGE>
<NAME>test.jpg</NAME>
<CAPTION><!&#91;CDATA&#91;<font color="#00ff33">Caption Text Goes Here</font>&#93;&#93;></CAPTION>
</IMAGE>

(No need to escape any characters in the captions.)

Steven Speirs
SimpleViewer Support Team.

Re: Title Font Problem

I understand what you're saying, but I'm not sure what's wrong. Here is the code in my gallery.xml:

<simpleviewerGallery maxImageWidth="500" maxImageHeight="500" textColor="0xffffff" frameColor="0x666666" frameWidth="10" stagePadding="40" thumbnailColumns="4" thumbnailRows="4" navPosition="left" title="&lt;font face="Times" size="28" color="#d5c19b"&gt;My Gallery&lt;/font&gt;" enableRightClickOpen="false" backgroundImagePath="" imagePath="" thumbPath="" >

All my text in the gallery is white with this code - title and all captions. The title isn't the color I want it. The title should be Times 28pt and a brownish color. What is wrong with my code? Does it have anything to do with the index.html?

Thanks again!

Re: Title Font Problem

There seems to be nothing wrong with your code at all.
I created a fresh "gallery.xml" using your header exactly as you posted it.

<simpleviewerGallery maxImageWidth="500" maxImageHeight="500" textColor="0xffffff" frameColor="0x666666" frameWidth="10" stagePadding="40" thumbnailColumns="4" thumbnailRows="4" navPosition="left" title="&lt;font face="Times" size="28" color="#d5c19b"&gt;My Gallery&lt;/font&gt;" enableRightClickOpen="false" backgroundImagePath="" imagePath="" thumbPath="" >

<IMAGE>
<NAME>sample_pic.jpg</NAME>
<CAPTION><!&#91;CDATA&#91;<font face="Times" color="#0000ff" size="12">Caption Text</font>&#93;&#93;></CAPTION>
</IMAGE>

</simpleviewerGallery>

All I did was add data for one image (with a caption) and closed it off with </simpleviewer Gallery>

When run, it does indeed show the title in Times, size 28 and light brown in color.  (It also shows the caption in Times, size 12 and blue in color.)  There is no white text to be seen anywhere.

Perhaps it is your version of SimpleViewer or Adobe Flash Player.
I am using SimpleViewer v1.85 and Adobe Flash Player v9.0.124.
Older versions might not handle the HTML formatting.

I would make sure you are using the latest versions of both SimpleViewer and Adobe Flash Player and try again.

If you are using the latest versions of both and the problem remains, then please post a url to your site so I can have a look at the completed album and try to figure out what is going on.

Steven Speirs
SimpleViewer Support Team.

Re: Title Font Problem

Well, I don't get it. I have all the code like you posted and it's still all one color. I also just downloaded Simpleviewer just this week or so, so I think it must be the most current version. I even updated my flash player. I'm stumped. The way I have it set up right now, it's:

<?xml version="1.0" encoding="UTF-8"?>
<simpleviewerGallery maxImageWidth="500" maxImageHeight="500" textColor="0x999999" frameColor="0x666666" frameWidth="10" stagePadding="40" thumbnailColumns="4" thumbnailRows="3" navPosition="left" title="&lt;font face="Times" size="28" color="#ffffff"&gt;art by rona.m&lt;/font&gt;" enableRightClickOpen="false" backgroundImagePath="" imagePath="" thumbPath="" >

I would post the site address but I can't, the forum won't let me.

I used the Photoshop script to construct the gallery. Does that have something to do with it?  :?:  :?:

Re: Title Font Problem

Not sure if this has anything to do with it but in gallery.xml the <font> declarations in the captions are not closed.

Also, for the first couple of images, you have an extra:

&#93;&#93;>

... near the end of the caption

eg. replace:

<caption><!&#91;CDATA&#91;<font size="16">girl series &#58;&#58; red umbrella &#40;nov06&#41;&#93;&#93;>&#93;&#93;></caption>

with:

<caption><!&#91;CDATA&#91;<font size="16">girl series &#58;&#58; red umbrella &#40;nov06&#41;</font>&#93;&#93;></caption>

I see you're also using SWFObject v1.4.1.
It might be worthwhile replacing it with SWFObject v1.5 from the SimpleViewer v1.85 download.

Try these changes and let me know how you get on.

Steven Speirs
SimpleViewer Support Team.

Re: Title Font Problem

Found the problem at last...

It is the viewer.swf file that seems to be the problem.
As soon as I swapped your viewer.swf for mine (unmodified free version), the title text changed color as expected.

Either your viewer.swf is not the latest version or there was a problem during the upload to your site.
Download the latest SimpleViewer v1.85 and upload the viewer.swf file to your site (replacing the existing one) and all should be well.

Steven Speirs
SimpleViewer Support Team.

Re: Title Font Problem

Yes! That was it! THANK YOU for all your help!

Re: Title Font Problem

Your welcome.

By the way, I think the artwork in the gallery is fantastic!

Steven Speirs
SimpleViewer Support Team.

Re: Title Font Problem

Thanks! I have one other quick question - is there any way to put the footer text right under the gallery window instead of at the very bottom of the page. Do you see what I mean?

I want it to be on the bottom right, directly under the simpleviewer link.

Re: Title Font Problem

If you just want to move the text up to the top right of the footer (which is where I think you want it) you could put a table within your <div> and align the text within the table like:

<div id="footer">
<table height="100%" width="100%">
<td style="text-align&#58; right; vertical-align&#58; top;">Text Goes Here</td>
</table>
</div>

It may not be an elegant solution but it gets the job done.
(Note that you might have to reformat your text within the table.)

If this is not where you want the text and I've got the wrong end of the stick, please try to explain further and I'll do my best to help.

Steven Speirs
SimpleViewer Support Team.