Topic: Aligning problems with postcardViewer movie

Hi.

I've made a presentation to be given in a CD-Rom, and I wanted to include a gallery section on my existing movie. So I pic up PostcardViewer Pro. I noticed that when I clicked the button to call the postcardviewer gallery on my main movie stage it showed with a different offset. I mean, the main movie that was supposed to be centered showed top-left aligned and the PCV showed centered.
I'm using an action at the begining of the main movie to set it to full screen.
I changed the setting of PCV to align bottom-center, and it show up better but even so, when I click the button to call the PCV gallery the (main) movie pushes to the bottom a few pixels, causing a small bar to apear at the top.
Not using the "full screen" action shows better, but I wanted to use "full screen".

What could be causing this?

thank you,

jrsilva

Re: Aligning problems with postcardViewer movie

I had read this Forum posts from side to side and didn't find a clue.
So I ask again, please.
Someone have an ideia of what's going on?
I need to have both host movie and gallery movie center aligned, and using Full Screen mode.


Thank you for reading this,


jrsilva

Re: Aligning problems with postcardViewer movie

Please,
I realy need to complete this task.

Re: Aligning problems with postcardViewer movie

Hi,

sorry for bumping this post, but I'm desperate.
Can someone point me what could be wrong?
I'm not a Action Script guru, so I don't know here in the code to search for something wrong. Even so, I've made several tests and changes.

It must be a small detail...
When I click to call the PCV gallery, when it loads, it push the host flash movie a few pixels down and remain like that, even if I click and go to another area of the host movie.


Thank you

Re: Aligning problems with postcardViewer movie

I'm having difficulty understanding your problem. When you say fullscreen do you mean using Flash fullscreen mode? Please restate your problem as concisely as possible.

Felix Turner
SimpleViewer Support Team.

Re: Aligning problems with postcardViewer movie

Hi,

glad you ear me.

I'll try to explain better:

I'm doing a presentation to go on a CD-Rom.
I'm using Flash 8 and Action Script 2.0.
There is a page of the presentation here I decided to put a button on the navigation bar that will call the external .SWF file with the PCV gallery.
On the first frame of my presentation movie I have: fscommand("fullscreen", "true");
to force the presentation to run on full screen.
This presentation movie is center aligned.


The problem:
When I click to load the (external) PCV gallery it showed up center aligned with the host movie, but push the host movie down a few pixels. I end up with a small bar on top of the movie but the bottom of the movie is close to the bottom of the screen.


I've tryed 2 methods:

1. Clicking that button sends to a frame where I put the following; loadmovieNum("images/projects.swf", 1);
(This "projects.swf" is the PCV gallery file)

2. I tryed also to use the Jumpeye component "Loader Pro v3" to force the gallery movie to load only inside the Loader window.
I do control better where I want the gallery to show up but unfortunely, I get the same empty area on top.

So, to resume, I'm trying to load the PCV gallery inside another Flash movie that goes full screen, but when the gallery loads it causes the overall movie to push down a few pixels, reveiling an empty area on top.

Thank you for your support.
looking forward for a clue.

jrsilva

Re: Aligning problems with postcardViewer movie

Hi,

I've tryed to post screen captures but I was not allowed to do it.
So, I've sent you a PM with the links.

Unfortunely my time is running out fast;
I've got until Sunday to finish the presentation.
I may have to gave up on using PCV.


Thank you once more,

jrsilva

Re: Aligning problems with postcardViewer movie

somebody... please?

Re: Aligning problems with postcardViewer movie

OK I looked at your screenshots. Still not getting what the problem is. You say your movie is resizing after you load the postcardviewer swf? Did you look at the code in the Flash Embed example FLA?

Felix Turner
SimpleViewer Support Team.

Re: Aligning problems with postcardViewer movie

I'm pulling my hair.

The movie does not resize.
The problem is:
when I load the gallery.swf movie (via a navigation button) inside my main presentation movie, the overall layout is pushed a few pixels to the bottom.
If you take another closer look at my screen shots, you will se that in the first one there is an equal size bar in top and in the bottom of the screen (this will depend on screen size), and when I click on the button on navbar to call the gallery all the stage of the main movie is pushed to the bottom and the bar on top of the screen increses in size and the bar at the bottom disapears because the movie was pushed to the bottom (as you can see on the 2nd screen shot). This may be something in the action script, but I'm no expert and I can't figure out. Even so, I've made some tests and played with the setings of the stage align; found that "T" it's the best for my project ("B" or "L", for example, caused a worst problem), but that's not enough. There's something more messing with the aligment of the main movie.

I can't be more specific than this.
I hope you had understand my problem.

Thank you,

Jaime Silva

Re: Aligning problems with postcardViewer movie

Note that PostcardViewer sets Stage.align to 'TL' and Stage.scaleMode to 'noScale' in the init() function at the top of the 'Main.as' file . You may need to remove this code if the embedding movie uses a different align or scalemode.

Stage.align = "TL"; 
Stage.scaleMode = "noScale";

This may be affecting your layout. To remove it, remove the above code, then republish your swf: http://www.airtightinteractive.com/proj … html#repub

Felix Turner
SimpleViewer Support Team.