Topic: SVpro & SVManager

Hi, I've been a fan of all the viewers provided by AIRTIGHT, and have purchased autoviewer pro and simpleviewer pro.  Recently I purchased SV Manager for use with a website I'm creating for a client.

The client wishes to create and update her own galleries by simply uploading and deleting images.  SV Manager has solved that problem.

However, my problem starts here:

I have modified SVpro so that it can display multiple galleries within itself.
The holding .swf contains three buttons which load up the relevant gallery.  I have 3 galleries in all.

What I want to be able to do is to use SV Manager to update the galleries that are being called into the holding.swf file.

I gave it a go myself, but when I rebuilt the gallery in SV Manager the gallery was viewable, but it contained itself, repeatedly, creating quite a funky pattern but with no images to display.

I know I'm on the right track and I've got a feeling its got something to do with the path to the gallery.xml files. 

I just wanted to know if anyone can give me some help on this or if anyone has managed to do what I'm doing, to give me a few pointers.

big_smile

Re: SVpro & SVManager

I've not tried integrating svManager to a multiple gallery swf like this, but it should be possible.

Essentially you will create your 3 svManager galleries as normal (each in it's own folder). Then create your multiple gallery swf in a seperate folder and set the 'xmlURL', 'imagePath' and 'thumbPath' options to point to the relevant folder when you load the gallery.

Felix Turner
SimpleViewer Support Team.

Re: SVpro & SVManager

I've made a similar gallery, and would similarly like to use SvManager to control it. my website in question is located at http://weliketobuild.com/portfolio/

you can also see that I've modified the SimpleViewer gallery to allow me more space for captions.

I'm curious if there is any evidence that the method posted by Felix was successful.

Re: SVpro & SVManager

Did you try importing the 3 sub-galleries into svManager?

Felix Turner
SimpleViewer Support Team.

Re: SVpro & SVManager

after a year's fiddling around, I finally found the answer to this question for myself: how to use svmanager with multiple galleries. If someone is in the same boat, let me know.

Re: SVpro & SVManager

Hi,

glad you got it working. Can you post what issue you hit and your solution so others can find it here? Thanks!

Felix Turner
SimpleViewer Support Team.

Re: SVpro & SVManager

I hope this makes sense, I'm just an amateur Flash guy:

My goal in the beginning was to design a Flash photo gallery for a photographer with no Flash knowledge. I also wanted to make the uploading and editing process very simple, and independent.    My plan was design a Flash site using the example for multiple galleries, and have a client use svmanager. It seems simple in theory, however, there were issues with the path compatibility:

If you were to use svmanager to produce a gallery (i.e. "gallery01"), it would kick out a "gallery01" folder containing the essential files:
gallery.xml
images (folder)
index.php
preferences.txt
readme.txt
swfobject.js
thumbs (folder)
viewer.swf

In the "Flash Embed/multiple_galleries.fla" example, the "gallery1.xml" file is not located in the same root folder as the "images" and "thumbs." Resulting in a paths that were not compatible.

There was a way around this, simply by altering the svmanager generated "gallery.xml."  By adding the correct path "gallery01/images/" to the imagePath and "galleryX/thumbs/" to the thumbPath. 

But this was an imperfect solution. It still didn't get the job done. My goal was to create gallery that any client could use, even with no html or flash knowledge.

I finally found the answer in the Simpleview v1.9 in the multiple_galleries.fla.  By changing the Options to imagePath and thumbPath to the desired path, it created a viewer.swf that was compatible with the svmanager galleries.

function onLoadInit() {
    //set gallery xml name
    _root.xmlDataPath = "gallery0"+galleryId+"/"+"gallery"+".xml";
    //set gallery specific options
    if (galleryId == 1) {
        com.airtightinteractive.apps.viewers.simpleViewer.Options.imagePath = "gallery01/images/";
        com.airtightinteractive.apps.viewers.simpleViewer.Options.thumbPath = "gallery01/thumbs/";
    }
    if (galleryId == 2) {
        com.airtightinteractive.apps.viewers.simpleViewer.Options.imagePath = "gallery02/images/";
        com.airtightinteractive.apps.viewers.simpleViewer.Options.thumbPath = "gallery02/thumbs/";
    }
}

I'm sure many smarter people have figured out better and easier ways to do this. But this was a big accomplishment for me.

Re: SVpro & SVManager

Hi guys, I was wondering if anyone has a solution for the autoplay option in v 1.9. That it would preload the next image before playing to the next image. I have posted it in many different places here in the forum, but no solution has been found, is there anyone that needs the same solution? It would be appreciated, if someone has a solution for this, share it here.

Re: SVpro & SVManager

Aren't all the images preloaded anyway?

Re: SVpro & SVManager

Thanks for the reply. smile

I'm sorry I didn't explain fully what I mean, the problem is there is a setting for display time, so if you set lets say 3 seconds, then it displays the picture for 3 seconds and goes to the next image but doesn't wait for the next image to preload. Say it carries on without displaying any image.
Hope this is understandable. Thanks

Re: SVpro & SVManager

Hi everyone,

as you can see, it's quite a while since I posted this previous message. Does no one else have this problem, with the autoplay option? If so, have you been able to fix it, by changing the source code? It would be really appreciated if someone can come with a solution, the autoplay option is very useful, but when it doesn't wait for the next image to preload, then it is useless. Hope to hear from someone with a solution.
Thanks in advance...

Re: SVpro & SVManager

honestly, i just don't understand your situation. I've seen your postings and I feel for you. This is not an issue that's causing any problems.  All the images are preloaded as it comes in. So why have the need to preload the "next" image again.  Unless your internet connection is slow enough where it can't handle loading a picture at least every 3 seconds.  All my images are loading within 10 seconds of entry and the autoplay whips through them with no stalls. I would love to help, but not clear on the need.

Re: SVpro & SVManager

Hi thanks for the reply, it is not difficult to undersand what I mean. If your images take 10 sec. to load and you press the play button, it will just play through all images without displaying them, because it takes the image 10 sec. to load, so 7 sec. to go, right?
What I need is that it will wait these 7 more seconds and then play to the next image and display it for 3 seconds. Do you understand now?
I could of course set the display time for 11 sec. but that is too long to wait for it to display the next one. What I also don't understand, everyone else gets a reply but I don't seem to be included in that group  sad
I'm not trying to be nasty, I just would appreciate if i'm also answered. I saw someone else have the same problem, that wasn't resolved. Only simple answers are answered as it seem :-) Hope to get an answer  big_smile
But there is good info here too...

Re: SVpro & SVManager

Hi,

delaying autoplay mode to handle image load times is not currently supported. The workaround is to decrease image file size and/or increase the autoplay delay until the images load safely in the given time.

You can modify the source code to handle this. Please check the docs section 2.4: http://www.airtightinteractive.com/simp … ml#source. Unfortunately I cannot offer step-by-step instructions on all possible modifications to the source code.

Felix Turner
SimpleViewer Support Team.

Re: SVpro & SVManager

how big are the file sizes for your images?  I think downsizing the images to the proper dimensions and resolution and then optimizing would be your best bet. But I assume you've tried that.  I scale mine down in the neighborhood of 120k maximum on each and I can have each loaded in a second.  Ten second load seems odd for any web load.  can you send an URL of your site?