Topic: Error cannot find gallery xml file g1gallery.xml

Hi,

   
I installed it on my localhost SVManager this working properly, but unfortunately when I upload my Hosting it gives me this error

- Error cannot find gallery xml file g1gallery.xml (gallery.php, line 145)
- into the javascript console : ($("Hmodel") has no properties)

Thanks  for your help

Re: Error cannot find gallery xml file g1gallery.xml

If you can fix the php error (Error cannot find...) then the javascript error will probably just go away.

The most likely cause of the php error is incorrect permissions. My best guess is that your web user does not have execute permissions on the main svmanager folder but it could be permissions elsewhere. So please check (or re-check) the permissions on all files and folders, following the guidelines in the user manual.

If this doesn't fix it, the next step is to create a new gallery and use ftp to check if the gallery.xml file is really not there or if it is there and svManager can't find it. Let me know the result and I'll think again.

jack

Jack Hardie
SimpleViewer Support Team.

Re: Error cannot find gallery xml file g1gallery.xml

Hi Jack,
I've changed my constants.php
-- Define ( 'DIR_MODE', 0777);
-- Define ( 'FILE_MODE', 0777);
but it's not work.
I have noticed that the new galery that I created on my local that does not work because I just create  a new gallery and it's work, I'll create back a new gallery directly in my hosting

Thank you for your reply

Marc

Re: Error cannot find gallery xml file g1gallery.xml

It looks like you should be ok now.

Just for information, the DIR_MODE and FILE_MODE constants only make a difference if you use the 'Unlist' option on the galleries page.

jack

Jack Hardie
SimpleViewer Support Team.