Topic: Please help me!

What am I doing wrong. I have been trying for days and I just can't get this to work. I have read and re-read the FAQs, Troubleshooting etc and searched this forum. If someone could please help I'd be eternally greatful because I'm losing my mind!!

Basically I have followed the manual instructions. All is fine locally on my hard drive, everything works as I'd like, even the back button and header.

When I upload to the FTP site this is the problem. The images and the thumbs need to be in a Folder (right?) So I have created them new folders on the FTP site, I've created a Folder called for eg: Sample and put images and thumbs plus the other documents in this new folder.

The HTML page which in my case I have to call 3.html (not index) because it has to link to my existing site is outside of this folder.

I have tried all combinations in the XML file and called the ImagePath "sample/images/" etc but the HTML file will not TALK to this folder and I just get black screen with text at the top to get Flash

With all the playing around I sometimes achieve just SimpleViewer showing but I can not get it to talk to the images or thumbs.

I am self taught and have no techy background. There just seems to be a link, something missing and I can't figure it out.

I even tried this code that Felix posted, but didn't work either.......


Yes that's possible. The swf, xml, images and thumbs can be in a different directory than the HTML file.

For example if your swf, xml, thumbs and images folders are in a sub-directory called gallery1, your HTML embed code will look like this:

Code:
var fo = new FlashObject("gallery1/viewer.swf", "viewer", "100%", "100%", "6", "#181818");       
      fo.addParam("quality", "best");
      fo.addVariable("xmlDataPath", "gallery1/imageData.xml");
      fo.write("flashcontent");



Then in your imageData.xml file, set your image and thumb path like this:

Code:
imagePath="gallery1/images/" thumbPath="gallery1/thumbs/"


please help
Cate

Re: Please help me!

I have spent about 13 hours on monday to make it work. So, hopefully i can give you a hint.

thats the way i had solved it.
( as soon as a step works, make a backup of your sv-scriptfiles)


1) erase all your simpleviewer data. backup your pictures.

2) unzip your simpleviewerdata and copy all script files and "images"
and "thumbs" to your site (offline)

3) no file/file/file.   think it is secure to keep it simple.

4) upload the untouched freshly unzipped simpleviewer data on your site.
let simpleviewer data INDEX be index. so this will start up.

5) CHECK, if the original content works. (if not, write to felix, if it does, go on)

6) now take 1 picture from your data, put this image and the thunb in the specific file (images and thumbs)

open imageData.cml and change the first entry (image-123, for example) into your image name.

7) uplead your added image, upload imageData.xml

8)open new browser window, start your site.
if it doesnT work, resave your image and the thumb. also check, if imageData.xml uses exactly the same imagename. (not: pic>> image_cate_1.jpg  and   imageData.xml>> IMAGE_Cate.jpg)


9)if it works, change all images and thumbs, write costumize your
imageData.xml    (not colors, just your imagelinks). Upload them
and watch your site.

10) if 9) so far doesnT work, erase your simpleviewer sciptfiles (not images and thumbs files)  on your server, and upload the costumized ones again. (helped in my case).

11) you than can change your simpleviewers name from index into anything else. if you want.




excuse my english, it isnT native, and i hope, that you will suceed. if not, i guess, lots of Memebrs here might have also a look into your Post.



with kind regards,
Matthias

Re: Please help me!

Thank you very much for your reply Mattes

But it's just not working.

My FTP explorer won't let me upload a folder I have to create a folder on the FTP site and then I uploaded the pictures and other files. However the index.html or as I've named it 3.html will not talk to that folder.

When I look at it online it's just a black page with blue writing at the top about getting Flash

Anyone else?

Felix?

I have been at this for days, I just can't work it out

Re: Please help me!

Hoorah! Have done it!!

Thanks

Re: Please help me!

Congrates! Glad you got it working.

My FTP explorer won't let me upload a folder I have to create a folder on the FTP

Try using ws_ftp  for up loading, it wiil save you alot of headaches.

Richard

Richard

in order to better assist you, please provide a url, relevant code and details about your problem.
Thanks!