Topic: Trouble with Firefox -- "wmode" error?

Hi,

I've been toying with SimpleViewer for a while now and I've achieved some great results.  Unfortunately, I've encountered a problem with FireFox (version 3).  Things function and look great in latest versions of Google Chrome as well as IE on PC.  (Haven't tried things on a Mac.)

I have a JavaScript menu sitting flesh against the top of my SV gallery.  I've implemented the fo.addParam("wmode", "opaque"); tag in my HTML which has allowed things to function properly in IE and other browsers.

However, in FireFox, while the menu opens above the image gallery, the image gallery is rendered useless.  All images and thumbnails load perfectly... things look perfect... but when you click on a thumbnail it indents as it should when it is pushed, but nothing happens.  No images load.

I've been able to isolate the problem to the "wmode" tag, because when I remove it, things work fine in FF but the menu appears behind the gallery.

Any way to fix this in FF without ruining the functionality in other browsers?


Interesting note: if you right click the gallery in FF a small, typical Flash settings tab pops up.  But then if you left click on a thumbnail, the image loads perfectly as it should.  It's as if you need to activate the gallery by right clicking it in order for it to respond correctly to pushing the thumbnails.  (You have to right click and then left click each time you want to select an image though... so this is not a suitable solution.)


-

Re: Trouble with Firefox -- "wmode" error?

UPDATE:
Try as I might, the error cannot be solved.  It seems either the menu is behind SimpleViewer, or the menu is in front and SimpleViewer loads but does not function.

After upgrading my computer from Flash Player 8 to Flash Player 9, the problem ceases to exist.  However, I am concerned for all those with earlier versions of Flash Player running on their systems that won't be able to access my website properly.

Perhaps there is a solution for this problem, or one can be worked out?

The issues deals with those that have Flash Player 8 plugin or earlier installed on their machines and who are using Firefox 3 and above.

Re: Trouble with Firefox -- "wmode" error?

Hi,

using wmode opaque is known to cause issues with certain browser/flash player combinations and is therefore not recommended. There are a couple of solutions :

a) redesign your page so you don't have HTML dropdowns over flash.
b) require flash 9 in the SWFObject declaration. Set the required flash player version as the 5th parameter in the SWFObject declaration in the HTML doc.

Felix Turner
SimpleViewer Support Team.

Re: Trouble with Firefox -- "wmode" error?

Thank you for your reply, Felix.

I think I will toy with the second option.  At the moment, I've put a link under the gallery viewer that reads, "Having Problems Viewing the Images?," which takes the visitor to the download page of Flash P 9.  I had no idea it was possible to require them to use Flash 9... that is a perfect solution in lue of some other kind of code fix.  I thank you.  (Also, moving the damn menu is a wise option as well;)

I wonder, Is there a way to create a requirement in the code for only FireFox users to operate with Flash P 9?  Perhaps that is impossible...

I appriciate your dedication to helping people out with this forum, Felix.  I spent some time browsing your Airtight site today and I am thankful for your talents and all that you've done with these Flash viewers and such.  Excellent job... you're making thousands of websites look that much better.  And in a world full of bad taste, I am thankful you're injecting a bit of your good taste into it.

big_smile

Re: Trouble with Firefox -- "wmode" error?

I would like to explore this due to some issues in firefox. What does the line look like?


b) require flash 9 in the SWFObject declaration. Set the required flash player version as the 5th parameter in the SWFObject declaration in the HTML doc.

Thanks in advance

Re: Trouble with Firefox -- "wmode" error?

var fo = new SWFObject("viewer.swf", "viewer", "100%", "100%", "8", "#181818");
Felix Turner
SimpleViewer Support Team.

Re: Trouble with Firefox -- "wmode" error?

Interesting, this is what I currently have in there,

        var fo = new SWFObject("viewer.swf", "simpleviewer", "480", "680", "8", "#000000");                       


i thought this would correct my issue of a drop down menu in firefox going behind the simpleviewer.

thanks for the help

Re: Trouble with Firefox -- "wmode" error?

Wondering if the inability of navigation drop downs to gov over a Simple Viewer slide show in FireFox has been resolved yet? Sometimes customers do not want things changed around.
Greatful for any assistance... thank you.

p.s. I got the fix for IE  fo.addParam("wmode", "opaque");   
(transparent also works)

brad

Re: Trouble with Firefox -- "wmode" error?

Wondering if the inability of navigation drop downs to gov over a Simple Viewer slide show in FireFox has been resolved yet?

There is no inability that I'm aware of. Setting the wmode to opaque will work for all browsers. If it's not working for you it may be some other CSS issue.

Felix Turner
SimpleViewer Support Team.

Re: Trouble with Firefox -- "wmode" error?

Thank you for your reply. This works in IE but not Safari or Firefox. I did read that in FF2 it worked but I believe in FF3 it does not. If you happen to get any more confirmation on this I would appreciate hearing. Also if you hear of a CSS reason why it would work perfect in IE & not FF I would appreciate any comments. Thank you again for your prompt reply.

brad

Re: Trouble with Firefox -- "wmode" error?

Ok with a little more brain work it appears to be working now in all browsers. Hope it keeps goin' - thank you.
brad