Topic: Thumb paging arrows are not displayed on 1.8.5 and 1.9

Hi all,

on 1.8.5 and 1.9, if navPosition is top or bottom, and there is only one row of thumbnails, then the thumbnail paging arrows are not displayed. However, if I click outside the last (and first) thumbnail in a row, the thumbs will scroll.

I tried swapping viewer.swf to a version before 1.8.5 (I don't know which, but it doesn't support navPadding so I recon it's pre-1.8.5), and that version did display the arrows. Unfortunately I can't use that version, because without navPadding, the images will slip under the captions.

I have tried changing the height of the SWFObject and the containing div, removing and adding XML settings, but got the same result. I used Flash Player 9 (under IE6, IE7, FF3).

Since this is my first post I cannot include a link, which is very annoying.
I hope this makes sense:
myweb tiscali co uk SLASH hazaselet SLASH simpleviewer SLASH


Many thanks for your help!
intellimouse

Re: Thumb paging arrows are not displayed on 1.8.5 and 1.9

I've just created a couple of galleries with one row of thumbnails; one with navPosition="top" and one with navPosition="bottom".
The thumbnail paging arrows display fine with both 1.8.5 and 1.9 (free versions).

Unfortunately the link you posted:
http://myweb.tiscali.co.uk/hazaselet/simpleviewer/
gives a 404 error so it's going to be difficult to help you further.

Steven Speirs
SimpleViewer Support Team.

Re: Thumb paging arrows are not displayed on 1.8.5 and 1.9

Many thanks monkeyboy for your help,

my apologies! To my great surprise, the link only works if the S and the V in simpleviewer are capital letters, like this:

myweb tiscali co uk/hazaselet/SimpleViewer/


Thanks!

Re: Thumb paging arrows are not displayed on 1.8.5 and 1.9

You have specified a width of 500 in:

var fo = new SWFObject("viewer.swf", "viewer", "500", "580", "8", "#222222");

This is simply too narrow to display the arrows as well as the thumbnails.
Change this value to '600' and you'll see the arrows appear as expected.

Steven Speirs
SimpleViewer Support Team.

Re: Thumb paging arrows are not displayed on 1.8.5 and 1.9

Thanks monkeyboy, I will try that.

With everything else unchanged, if I set the number of thumbnail rows to 2, the arrows will be displayed under the thumbs (like a third row), even if I leave it in the same 500px div. (Like the small format demo on the Airtight site, which is 480px wide.)

Older versions of SimpleViewer also display the arrows under the single row of thumbnails, in the same 500px div.


Is this then a design feature of recent versions, to have the arrows displayed in line with the thumbs if there is only one row of thumbs, and below them if there are more rows?

Re: Thumb paging arrows are not displayed on 1.8.5 and 1.9

Is this then a design feature of recent versions, to have the arrows displayed in line with the thumbs if there is only one row of thumbs, and below them if there are more rows?

I'm afraid I can't answer that. I've only ever used v1.8.5 and v1.9 and don't have any older versions to try it with.

Steven Speirs
SimpleViewer Support Team.

Re: Thumb paging arrows are not displayed on 1.8.5 and 1.9

Thinking about it, an alternative solution might be (instead of increasing the size of the div) to decrease the number of thumbnail columns in gallery.xml to something like thumbnailColumns="4" (keeping the rows at "1").

Steven Speirs
SimpleViewer Support Team.

Re: Thumb paging arrows are not displayed on 1.8.5 and 1.9

Yes that's precisely what I did: changed thumbnailColumns to 5. This left enough room for the arrows to be displayed to the left and the right smile

Now I feel like an idiot... I think I'm gonna suggest adding this feature change to the version history.
1.8 has a "Tweaked thumbnail UI", I guess that's what this is.

Many thanks for your help monkeyboy!

Re: Thumb paging arrows are not displayed on 1.8.5 and 1.9

Is this then a design feature of recent versions, to have the arrows displayed in line with the thumbs if there is only one row of thumbs, and below them if there are more rows?

Yes.

Felix Turner
SimpleViewer Support Team.

Re: Thumb paging arrows are not displayed on 1.8.5 and 1.9

Thanks Felix,

awesome feature BTW, much better than having the arrows under the thumbnail row! (Great app as well.)


I think it would be useful to have this change of feature added to the version history.

(All SV galleries that I could find had the arrows underneath, either because they used multiple rows of thumbs, or they were older versions. So I didn't understand why mine didn't work (while it did actually work just the way it was intended). Reading the version history didn't help... I wasn't sure what "Tweaked thumbnail UI" meant.)