Topic: build_av_gallery.php won't work

Hello everybody, this is Emilio from Italy. I've seen Autoviewer on a website and I like it a lot. I tried it on my website by modifying it manually, and it works. However, when I tried the automatic method via Server-side Script, I just can't seem to be able to create a new gallery.xml file. I don't know what I'm doing wrong, as I've followed all of the instructions on the /projects/autoviewer/auto_server_instruct page.

The page I get displayed every time is this:

Creating XML for Autoviewer.
-------------------------------------------------

Sorting images by date.
Sorting images in reverse order.

- Created Image Entry for: 9.jpg whose width is 500 and whose height is 333.
- Created Image Entry for: 8.jpg whose width is 333 and whose height is 500.
- Created Image Entry for: 7.jpg whose width is 333 and whose height is 500.
- Created Image Entry for: 3.jpg whose width is 333 and whose height is 500.
- Created Image Entry for: 2.jpg whose width is 500 and whose height is 333.
- Created Image Entry for: 16.jpg whose width is 333 and whose height is 500.
- Created Image Entry for: 15.jpg whose width is 500 and whose height is 333.
- Created Image Entry for: 14.jpg whose width is 500 and whose height is 333.
- Created Image Entry for: 13.jpg whose width is 500 and whose height is 333.
- Created Image Entry for: 12.jpg whose width is 500 and whose height is 333.
- Created Image Entry for: 11.jpg whose width is 333 and whose height is 500.
- Created Image Entry for: 10.jpg whose width is 333 and whose height is 500.
- Created Image Entry for: 6.jpg whose width is 500 and whose height is 333.
- Created Image Entry for: 5.jpg whose width is 333 and whose height is 500.
- Created Image Entry for: 4.jpg whose width is 500 and whose height is 333.
- Created Image Entry for: 1.jpg whose width is 333 and whose height is 500.

Warning: fopen(gallery.xml) [function.fopen]: failed to open stream: Permission denied in D:inetpubwebsicwwrestlingitautoviewerbuild_av_gallery.php on line 81

Cannot open XML document: gallery.xml

Warning: fclose(): supplied argument is not a valid stream resource in D:inetpubwebsicwwrestlingitautoviewerbuild_av_gallery.php on line 88


Can you please help me sort this out? Thanks a lot in advance.

Emilio

Re: build_av_gallery.php won't work

hello, this is Z from Taiwan.

Could you right click the gallery.xml file,
and unchecked the "read only" option of the gallery.xml file
then try again.

Good luck
big_smile