Topic: Tiltviewer not working with Flickr Account

I have successfully gotten this to work using the XML sheet, and the folder full of images named img1/img2/img3/img4 etc


However this was my last resort, I originally tried getting it to work using my Flickr account because since I run a non-profit site and have another person I trust access to, as far as uploading images from events, it would be easy for us to maintain and keep a very up to date picture gallery.

I have a FREE Flickr account (not sure why it would matter as it is indeed unlocked and public to not restrict Tiltviewer from grabbing the tagged photos), but for some reason, every time I try to do it it does not work.  I know it does not work from the local machine, and it has been uploaded to my server, but still it does not go out and grab the pictures.  Its a somewhat fresh Flickr account that I never used much before this, and I have added the appropriate tag to all the photos so it would pick them up in bulk.  I also made sure as to take out the //comment tags to enable it.  As well as turning the Flickr option on of course with the value of true.  Adding my flicker account etc.

I pretty much followed everything in the FAQ, and also read the entire HTML page to see if there were anything that needed to be closed or activated by removing or adding comment slashes.

I would MUCH MUCH rather have the images load from Flickr, as the genius that made this software had the intentions of making it possible, which is seriously one of the reasons why I absolutely fell in love with this software when reading about it, I just don't love how I can't get it to work.  haha

I will post up what I am using for HTML code here, if anyone can help me get a head start, my Flickr Account will be in there too.  It may be a simple mistake (which is all I can think of as the XML and local folder with pictures option works when I do it that way, but its a hassle compared to doing it on Flickr, esp with 2 people who will be adding photos every so often instead of a 1 man show).


Here is my index html file:

(i had to edit out the portions with web addresses as your forum was blocking them out (spam protection I assume from what I read quickly))

//FLICKR GALLERY OPTIONS
        // To use images from Flickr, uncomment this block
        fo.addVariable("useFlickr", "true");
        fo.addVariable("user_id", "10112071@N03");
        fo.addVariable("tags", "nemo");
        fo.addVariable("tag_mode", "all");
        fo.addVariable("showTakenByText", "true");           
       
        // XML GALLERY OPTIONS
        // To use local images defined in an XML document, use this block       
        fo.addVariable("useFlickr", "true");
        //fo.addVariable("xmlURL", "gallery.xml");
        fo.addVariable("maxJPGSize","1024");
       
        //GENERAL OPTIONS       
        fo.addVariable("useReloadButton", "false");
        fo.addVariable("columns", "5");
        fo.addVariable("rows", "5");
        //fo.addVariable("showFlipButton", "true");
        //fo.addVariable("showLinkButton", "true");       
        //fo.addVariable("linkLabel", "View image info");
        //fo.addVariable("frameColor", "0xFF0000");
        //fo.addVariable("backColor", "0xDDDDDD");
        //fo.addVariable("bkgndInnerColor", "0xFF00FF");
        //fo.addVariable("bkgndOuterColor", "0x0000FF");               
        //fo.addVariable("langGoFull", "Go Fullscreen");
        //fo.addVariable("langExitFull", "Exit Fullscreen");
        //fo.addVariable("langAbout", "About");               
       
        // END TILTVIEWER CONFIGURATION OPTIONS


My flickr account is 10112071@N03

And the tags I added to my images with the bulk uploader is: nemo

This is probably the easiest configurable website element I have ever used, and again, thank you so much for making such a wonderful thing and providing a free version, but for the life of me I could not figure out what was wrong and why it was not working lol

Thank you so much for any help!   big_smile


The tiltviewer app works, but its just blank and will not grab my photos sad

Re: Tiltviewer not working with Flickr Account

Fixed the issue on my own, can only have one  fo.addVariable("useFlickr", "true"); instead of 2, cancels eachother out.

Thank you for having a support forum out but I caught my mistake just in time


I do have one question however now that I have it working. I just uploaded 2 folders of pictures, each have a separate tag to differentiate from eachother.  But Tiltviewer is grabbing them in a random order, jumbled, instead of one after another.  Is there any particular way, or option in the HTML I need so I can have one group of photos load completely, say Ford cars 1-10, then after that, Honda cars 1-10, instead of them all being mixed?  I thought the different tags on the photos would do this, but I guess not.