Topic: Please help! Need requirements for server

Hi, I've posted a few times under another topic asking for help. My gallery works fine on my desktop, and other servers but does NOT work on the server my client is using. It gives an error message "gallery not found", yes, my xml file is there.

Please give me some requirements I can pass on to this hosting company. I have found them to be outdated in the past and really feel like  it must be something on their end but do not know how to pinpoint it. Surely you must have a set of requirements. This issue has been ongoing for over a month. Really need help.


Re: Please help! Need requirements for server

Maybe the path to your xml file is not correct.

You can change the path in the preloader MC in the simpleviewer.fla:

//load XM data

//set default xmlPath
var xmlPath = "xml/showroom.xml"

or in the javascript of the index.html:

//fo.addVariable("xmlDataPath", "gallery.xml");

or, if you use multiple galleries within another swf in the code of this swf as it is shown in the examples of simpleviewer (simpleviewer_proexamplesFlash Embed):

function onLoadInit(){
    //set gallery xml name
    _root.xmlDataPath = "gallery"+galleryId + ".xml";

And last but not least: you have to set the rights of the directory which contains your xml-files to 755.

Re: Please help! Need requirements for server

SimpleViewer has no special web server requirements. The server just needs to handle HTML and SWF files. Also image hotlink protection must be turned off.

whats the url to your gallery?

Felix Turner
SimpleViewer Support Team.